summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcelo Garlet Millani2015-07-04 11:54:30 -0300
committerMarcelo Garlet Millani2015-07-04 11:54:30 -0300
commit5b8858259099aad6a97d69551addfe442840b5b6 (patch)
tree6340a52ca2354fab78afb5e9c7c7f8e6014a2591
downloadaur-5b8858259099aad6a97d69551addfe442840b5b6.tar.gz
Moving from AUR3 to AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
-rw-r--r--haskell-descrilo.install18
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ffc06aee12b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haskell-descrilo
+ pkgdesc = Loads a list of items with fields
+ pkgver = 0.1.0.3
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/descrilo
+ install = haskell-descrilo.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = ghc
+ source = http://hackage.haskell.org/package/descrilo-0.1.0.3/descrilo-0.1.0.3.tar.gz
+ sha256sums = 82479f64aa13a8df7fafcf091ea34ca7044fad2e582489772fb1b46c3645a7a7
+
+pkgname = haskell-descrilo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..badfce117b29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Marcelo Garlet Millani <marcelogmillani at gmail dot com>
+_hkgname=descrilo
+pkgname=haskell-descrilo
+pkgver=0.1.0.3
+pkgrel=1
+pkgdesc='Loads a list of items with fields'
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('GPL3')
+arch=('i686' 'x86_64') # should work for any arch which haskell may be compiled to
+depends=("ghc")
+source=( "http://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz" )
+#options=('staticlibs')
+install=${pkgname}.install
+sha256sums=('82479f64aa13a8df7fafcf091ea34ca7044fad2e582489772fb1b46c3645a7a7')
+
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+
+ runhaskell Setup configure -O --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ # runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O --enable-shared --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ mkdir -p ${pkgdir}/usr/share/man/man5
+ install -D -m 0644 descrilo.5 ${pkgdir}/usr/share/man/man5/
+ gzip ${pkgdir}/usr/share/man/man5/descrilo.5
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
+
diff --git a/haskell-descrilo.install b/haskell-descrilo.install
new file mode 100644
index 000000000000..573126d58545
--- /dev/null
+++ b/haskell-descrilo.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-descrilo
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+# ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}