summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcelo Garlet Millani2017-12-26 12:18:08 +0100
committerMarcelo Garlet Millani2017-12-26 12:18:08 +0100
commitb9adc68ca02e0ade19ca902004935e9b1c586df3 (patch)
tree8a07048c20556a69df4ba1d7ceb2bb9afcc03506
parentc9a26ab4f2ec3fa7afd83f035ef6561eb7a2faa0 (diff)
downloadaur-b9adc68ca02e0ade19ca902004935e9b1c586df3.tar.gz
Dynamic flag for haddock.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43a83527eb92..928f8927b6e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = haskell-descrilo
pkgdesc = Loads a list of items with fields
pkgver = 0.1.0.5
- pkgrel = 1
+ pkgrel = 2
url = http://hackage.haskell.org/package/descrilo
install = haskell-descrilo.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 58807088ff80..840efbd849d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_hkgname=descrilo
pkgname=haskell-descrilo
pkgver=0.1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc='Loads a list of items with fields'
url="http://hackage.haskell.org/package/${_hkgname}"
license=('GPL3')
@@ -16,12 +16,14 @@ sha256sums=('2531d6b52a6a1a44c00581d952631401cadb3e3b2c9f6111fbdc05ad17b3f58e')
build() {
cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure -O --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
- runhaskell Setup build
- runhaskell Setup haddock
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
+ runhaskell Setup configure -O --enable-shared --prefix=/usr \
+ --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option -dynamic
+ runhaskell Setup build
+ runhaskell Setup haddock --haddock-options "--optghc -dynamic"
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
package() {