summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaron Kent-Dobias2019-02-06 17:43:58 -0500
committerJaron Kent-Dobias2019-02-06 17:43:58 -0500
commitc7f0ff456f6ffe918e852cd3c862126a7920e048 (patch)
tree45c5533e7084289249f26c04da7846535e01288a
downloadaur-c7f0ff456f6ffe918e852cd3c862126a7920e048.tar.gz
new repo
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD46
-rw-r--r--haskell-diagrams-postscript.patch26
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..700da41bed16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = haskell-diagrams-postscript
+ pkgdesc = A modular backend for rendering diagrams created with the diagrams EDSL using Postscript.
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/diagrams-diagrams-postscript
+ arch = x86_64
+ license = BSD-3
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-containers
+ depends = haskell-data-default-class
+ depends = haskell-diagrams-core
+ depends = haskell-diagrams-lib
+ depends = haskell-dlist
+ depends = haskell-hashable
+ depends = haskell-lens
+ depends = haskell-monoid-extras
+ depends = haskell-split
+ depends = haskell-statestack
+ source = https://hackage.haskell.org/package/diagrams-postscript-1.4.1/diagrams-postscript-1.4.1.tar.gz
+ source = haskell-diagrams-postscript.patch
+ sha512sums = 4e9b1e270c60bdd4ae607320f967be636a1dcd5e8df14983f3194fa2c011989ac0a63436b2a3cfb6775d24096991c577e40f42b0b6a954a6d00d6eeb5f86578f
+ sha512sums = aeb9c9624ebce879d3ec6fe1297233e48776ebe36dbafe2b14e61fa1025cdc7b8e9b37bb035f9f51f60ec0835585f7b3af078bc2174999fd56a114c0e4306718
+
+pkgname = haskell-diagrams-postscript
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c56227a359e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+
+_hkgname=diagrams-postscript
+pkgname=haskell-diagrams-postscript
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="A modular backend for rendering diagrams created with the diagrams EDSL using Postscript."
+url="https://hackage.haskell.org/package/diagrams-diagrams-postscript"
+license=("BSD-3")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-containers' 'haskell-data-default-class' 'haskell-diagrams-core' 'haskell-diagrams-lib' 'haskell-dlist' 'haskell-hashable' 'haskell-lens' 'haskell-monoid-extras' 'haskell-split' 'haskell-statestack')
+makedepends=('ghc')
+source=(https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz
+ haskell-diagrams-postscript.patch)
+sha512sums=('4e9b1e270c60bdd4ae607320f967be636a1dcd5e8df14983f3194fa2c011989ac0a63436b2a3cfb6775d24096991c577e40f42b0b6a954a6d00d6eeb5f86578f'
+ 'aeb9c9624ebce879d3ec6fe1297233e48776ebe36dbafe2b14e61fa1025cdc7b8e9b37bb035f9f51f60ec0835585f7b3af078bc2174999fd56a114c0e4306718')
+
+prepare() {
+ cd ${_hkgname}-${pkgver}
+ patch -Np1 -i "${srcdir}/haskell-diagrams-postscript.patch"
+}
+
+build() {
+ cd ${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -dm 755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/haskell-diagrams-postscript.patch b/haskell-diagrams-postscript.patch
new file mode 100644
index 000000000000..66498b9cb1d3
--- /dev/null
+++ b/haskell-diagrams-postscript.patch
@@ -0,0 +1,26 @@
+diff -rua diagrams-postscript-1.4.1/diagrams-postscript.cabal diagrams-postscript-1.4.1.new/diagrams-postscript.cabal
+--- diagrams-postscript-1.4.1/diagrams-postscript.cabal 2018-05-23 07:07:45.000000000 -0400
++++ diagrams-postscript-1.4.1.new/diagrams-postscript.cabal 2019-02-06 17:42:22.593078098 -0500
+@@ -34,7 +34,7 @@
+ Diagrams.Backend.Postscript.CmdLine
+ Graphics.Rendering.Postscript
+ Hs-source-dirs: src
+- Build-depends: base >= 4.2 && < 4.12,
++ Build-depends: base >= 4.2,
+ mtl >= 2.0 && < 2.3,
+ dlist >= 0.5 && < 0.9,
+ diagrams-core >= 1.3 && < 1.5,
+@@ -42,10 +42,9 @@
+ data-default-class < 0.2,
+ statestack >= 0.2 && < 0.3,
+ split >= 0.1.2 && < 0.3,
+- monoid-extras >= 0.3 && < 0.5,
+- semigroups >= 0.3.4 && < 0.19,
+- lens >= 4.0 && < 4.17,
+- containers >= 0.3 && < 0.6,
++ monoid-extras >= 0.3,
++ lens >= 4.0,
++ containers >= 0.3,
+ hashable >= 1.1 && < 1.3
+ if impl(ghc < 7.6)
+ build-depends: ghc-prim