summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcbpark2017-06-12 00:35:53 +0900
committercbpark2017-06-12 00:35:53 +0900
commitadc1d534458be0e7dfd61f51baa9177be8f29445 (patch)
tree01710aea5140fb69d57f9a27d40bfc59a716dea6
parent9d0850f39d8397f760fd2da3cb95cfe9f2b793f8 (diff)
downloadaur-adc1d534458be0e7dfd61f51baa9177be8f29445.tar.gz
upgpkg: haskell-ghc-exactprint 0.5.4.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e038b6edc813..e3a1d6d4ff43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,25 @@
pkgbase = haskell-ghc-exactprint
- pkgdesc = GHC version of haskell-src-exts exactPrint
- pkgver = 0.5.3.1
+ pkgdesc = Using the API Annotations available from GHC 7.10.2, this library provides a means to round trip any code that can be compiled by GHC, currently excluding lhs files.
+ pkgver = 0.5.4.0
pkgrel = 1
url = https://hackage.haskell.org/package/ghc-exactprint
arch = i686
arch = x86_64
license = custom:BSD3
depends = ghc>=7.10.2
+ depends = haskell-diff
+ depends = haskell-filemanip
+ depends = haskell-free
depends = haskell-ghc-paths>=0.1
+ depends = haskell-hunit
depends = haskell-mtl>=2.2.1
depends = haskell-syb>=0.5
- depends = haskell-free>=4.12
+ depends = haskell-temporary
depends = haskell-text>=1.2.2
depends = haskell-turtle>=1.3.0
- source = http://hackage.haskell.org/packages/archive/ghc-exactprint/0.5.3.1/ghc-exactprint-0.5.3.1.tar.gz
- sha256sums = 54f2b83a8643e25654e4dfaf236938021e37c82e22d589d45ffb43aef2483772
+ options = strip
+ source = https://hackage.haskell.org/package/ghc-exactprint-0.5.4.0/ghc-exactprint-0.5.4.0.tar.gz
+ sha256sums = d39a76c0659290075adb053c22fe4147c395a8e29f512008b16de418039aeece
pkgname = haskell-ghc-exactprint
diff --git a/PKGBUILD b/PKGBUILD
index 0544af7763c6..5eec6ae40669 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,26 @@
_hkgname=ghc-exactprint
pkgname=haskell-ghc-exactprint
-pkgver=0.5.3.1
+pkgver=0.5.4.0
pkgrel=1
-pkgdesc="GHC version of haskell-src-exts exactPrint"
+pkgdesc="Using the API Annotations available from GHC 7.10.2, this library provides a means to round trip any code that can be compiled by GHC, currently excluding lhs files."
arch=('i686' 'x86_64')
url="https://hackage.haskell.org/package/${_hkgname}"
license=("custom:BSD3")
-depends=("ghc>=7.10.2" "haskell-ghc-paths>=0.1" "haskell-mtl>=2.2.1" "haskell-syb>=0.5" "haskell-free>=4.12" "haskell-text>=1.2.2" "haskell-turtle>=1.3.0")
-source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha256sums=('54f2b83a8643e25654e4dfaf236938021e37c82e22d589d45ffb43aef2483772')
+depends=("ghc>=7.10.2"
+ "haskell-diff"
+ "haskell-filemanip"
+ "haskell-free"
+ "haskell-ghc-paths>=0.1"
+ "haskell-hunit"
+ "haskell-mtl>=2.2.1"
+ "haskell-syb>=0.5"
+ "haskell-temporary"
+ "haskell-text>=1.2.2"
+ "haskell-turtle>=1.3.0")
+options=('strip')
+source=("https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('d39a76c0659290075adb053c22fe4147c395a8e29f512008b16de418039aeece')
build() {
cd "${srcdir}/${_hkgname}-${pkgver}"