summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-09 09:03:51 -0400
committerSolomon Choina2018-06-09 09:03:51 -0400
commitae042f30d9c97d978a8f8cff7c7bc2cd00aff011 (patch)
tree847074ce7473e98fb6ada7c2ef6d2d3c3a8f9702
downloadaur-ae042f30d9c97d978a8f8cff7c7bc2cd00aff011.tar.gz
initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD43
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a8cce1195cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = haskell-gi-dbusmenugtk3
+ pkgdesc = Bindings for libdbusgtk3, autogenerated by haskell-gi.
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/gi-dbusmenugtk3
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = ghc
+ depends = haskell-base
+ depends = ghc-libs
+ depends = haskell-bytestring
+ depends = haskell-containers
+ depends = haskell-gi-atk
+ depends = haskell-gi-dbusmenu
+ depends = haskell-gi-gdk
+ depends = haskell-gi-gdkpixbuf
+ depends = haskell-gi-glib
+ depends = haskell-gi-gobject
+ depends = haskell-gi-gtk
+ depends = haskell-gi
+ depends = haskell-gi-base
+ depends = haskell-gi-overloading
+ depends = haskell-text
+ depends = haskell-transformers
+ depends = libdbusmenu-gtk3
+ source = https://hackage.haskell.org/packages/archive/gi-dbusmenugtk3/0.4.2/gi-dbusmenugtk3-0.4.2.tar.gz
+ sha256sums = 9c746b7cdd2703ea18c86beb7b1e8d9a2ee2e6be3237acc50f576cc5a2efd471
+
+pkgname = haskell-gi-dbusmenugtk3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4605c0c0d73a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-dbusmenugtk3
+_hkgname=gi-dbusmenugtk3
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="Bindings for libdbusgtk3, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-dbusmenugtk3
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=( 'haskell-base' 'ghc-libs' 'haskell-bytestring'
+'haskell-containers' 'haskell-gi-atk' 'haskell-gi-dbusmenu' 'haskell-gi-gdk'
+'haskell-gi-gdkpixbuf' 'haskell-gi-glib' 'haskell-gi-gobject'
+'haskell-gi-gtk' 'haskell-gi' 'haskell-gi-base'
+'haskell-gi-overloading' 'haskell-text' 'haskell-transformers' 'libdbusmenu-gtk3')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('9c746b7cdd2703ea18c86beb7b1e8d9a2ee2e6be3237acc50f576cc5a2efd471')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}