summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-08 19:30:41 -0400
committerSolomon Choina2018-06-08 19:30:41 -0400
commit9fbab445cd9f44f81595f67cc11c3097ad8d2398 (patch)
tree945ac9037c19e4aebb45f38c22ac8cfe586fb2f2
downloadaur-9fbab445cd9f44f81595f67cc11c3097ad8d2398.tar.gz
initial import
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD39
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f31ab226623f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = haskell-gi-gdk
+ pkgdesc = Bindings for Gdk, autogenerated by haskell-gi.
+ pkgver = 3.0.16
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/gi-gdk
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-gi-base
+ depends = haskell-base
+ depends = haskell-bytestring
+ depends = haskell-containers
+ depends = haskell-gi
+ depends = haskell-gi-cairo
+ depends = haskell-gi-gio
+ depends = haskell-gi-overloading
+ depends = haskell-text
+ depends = haskell-transformers
+ depends = haskell-gi-gobject
+ depends = haskell-gi-gdkpixbuf
+ depends = haskell-gi-pango
+ depends = gtk3
+ source = https://hackage.haskell.org/packages/archive/gi-gdk/3.0.16/gi-gdk-3.0.16.tar.gz
+ sha256sums = 7eb0aa493d268cd040c7ff70ad09d7bf7787e0e7619617ba220b88eafe68e34a
+
+pkgname = haskell-gi-gdk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f743aa03c488
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-gdk
+_hkgname=gi-gdk
+pkgver=3.0.16
+pkgrel=1
+pkgdesc="Bindings for Gdk, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-gdk
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=("ghc-libs" 'haskell-gi-base' 'haskell-base' 'haskell-bytestring' 'haskell-containers' 'haskell-gi' 'haskell-gi-cairo' 'haskell-gi-gio' 'haskell-gi-overloading' 'haskell-text' 'haskell-transformers' 'haskell-gi-gobject' 'haskell-gi-gdkpixbuf' 'haskell-gi-pango' 'gtk3')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('7eb0aa493d268cd040c7ff70ad09d7bf7787e0e7619617ba220b88eafe68e34a')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}