summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-08 19:09:47 -0400
committerSolomon Choina2018-06-08 19:09:47 -0400
commit7dc558be2e5fb7deabaa13dc122ee925181f8dc5 (patch)
treedeb4fc4e0d39b02206f1d136758915960d67f0db
downloadaur-7dc558be2e5fb7deabaa13dc122ee925181f8dc5.tar.gz
initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD39
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28c2b9608c8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = haskell-gi-gdkpixbuf
+ pkgdesc = Bindings for Gio, autogenerated by haskell-gi.
+ pkgver = 2.0.16
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/gi-gio
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-gi-base
+ depends = haskell-base
+ depends = haskell-bytestring
+ depends = haskell-containers
+ depends = haskell-gi
+ depends = haskell-gi-gio
+ depends = haskell-gi-overloading
+ depends = haskell-text
+ depends = haskell-transformers
+ depends = haskell-gi-gobject
+ depends = gdk-pixbuf2
+ source = https://hackage.haskell.org/packages/archive/gi-gdkpixbuf/2.0.16/gi-gdkpixbuf-2.0.16.tar.gz
+ sha256sums = fdbb5f12ecd3a419a345919913e659f90000b38b973ce79fb6e9ba05f5d4166f
+
+pkgname = haskell-gi-gdkpixbuf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4430f46fea1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-gdkpixbuf
+_hkgname=gi-gdkpixbuf
+pkgver=2.0.16
+pkgrel=1
+pkgdesc="Bindings for Gio, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-gio
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=("ghc-libs" 'haskell-gi-base' 'haskell-base' 'haskell-bytestring' 'haskell-containers' 'haskell-gi' 'haskell-gi-gio' 'haskell-gi-overloading' 'haskell-text' 'haskell-transformers' 'haskell-gi-gobject' 'gdk-pixbuf2')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('fdbb5f12ecd3a419a345919913e659f90000b38b973ce79fb6e9ba05f5d4166f')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}