summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-08 20:06:30 -0400
committerSolomon Choina2018-06-08 20:06:30 -0400
commit75e6f3228fda6e337e27bb820213440aff0121ec (patch)
treeb8d87de0c2937006172601ae98c6a0f9a3ef9ad5
downloadaur-75e6f3228fda6e337e27bb820213440aff0121ec.tar.gz
initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d88e4f80bda3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = haskell-gi-gdkx11
+ pkgdesc = Bindings for GdkX11, autogenerated by haskell-gi.
+ pkgver = 3.0.2
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/gi-gdkx11
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-gi-base
+ depends = haskell-base
+ depends = haskell-bytestring
+ depends = haskell-containers
+ depends = haskell-gi
+ depends = haskell-gi-overloading
+ depends = haskell-text
+ depends = haskell-transformers
+ depends = haskell-gi-xlib
+ depends = haskell-gi-gdk
+ source = https://hackage.haskell.org/packages/archive/gi-gdkx11/3.0.2/gi-gdkx11-3.0.2.tar.gz
+ sha256sums = 4cc93329af472ba46572784e1d6b9a5ac25c237381a0462a14db5c6390cf7168
+
+pkgname = haskell-gi-gdkx11
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58367f7cb4bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-gdkx11
+_hkgname=gi-gdkx11
+pkgver=3.0.2
+pkgrel=1
+pkgdesc="Bindings for GdkX11, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-gdkx11
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=("ghc-libs" 'haskell-gi-base' 'haskell-base' 'haskell-bytestring' 'haskell-containers' 'haskell-gi' 'haskell-gi-overloading' 'haskell-text' 'haskell-transformers' 'haskell-gi-xlib' 'haskell-gi-gdk')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('4cc93329af472ba46572784e1d6b9a5ac25c237381a0462a14db5c6390cf7168')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}