summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-08-08 00:23:16 -0400
committerSolomon Choina2019-08-08 00:23:16 -0400
commit60a5d98afabff425525ff9c11498513e09be908b (patch)
tree1d6218cf53c145a58c035e8c3962c382da51add4
downloadaur-60a5d98afabff425525ff9c11498513e09be908b.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD42
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00e26534ba5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = haskell-gi-gsk
+ pkgdesc = Bindings for gsk, autogenerated by haskell-gi.
+ pkgver = 4.0.1
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/gi-gsk
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-bytestring
+ depends = haskell-containers
+ depends = haskell-gi-gdk
+ depends = haskell-gi-cairo
+ depends = haskell-gi-glib
+ depends = haskell-gi-gobject
+ depends = haskell-gi-pango
+ depends = haskell-gi
+ depends = haskell-gi-base
+ depends = haskell-gi-overloading
+ depends = haskell-text
+ depends = haskell-transformers
+ depends = haskell-gi-graphene
+ source = https://hackage.haskell.org/packages/archive/gi-gsk/4.0.1/gi-gsk-4.0.1.tar.gz
+ sha256sums = dd0ef5761336df9010ffd8b38c0ed26240e59a55c2fdfc07e8a399e7a26f8518
+
+pkgname = haskell-gi-gsk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea03679374c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-gsk
+_hkgname=gi-gsk
+pkgver=4.0.1
+pkgrel=1
+pkgdesc="Bindings for gsk, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-gsk
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=('ghc-libs' 'haskell-bytestring'
+'haskell-containers' 'haskell-gi-gdk' 'haskell-gi-cairo'
+'haskell-gi-glib' 'haskell-gi-gobject' 'haskell-gi-pango'
+'haskell-gi' 'haskell-gi-base' 'haskell-gi-overloading' 'haskell-text' 'haskell-transformers' 'haskell-gi-graphene')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('dd0ef5761336df9010ffd8b38c0ed26240e59a55c2fdfc07e8a399e7a26f8518')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}