summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-08 22:56:00 -0400
committerSolomon Choina2018-06-08 22:56:00 -0400
commit685f8e54236bdd730f400d1c2b6154936951a7fc (patch)
tree97e784454735e4404e71392fd087f41c632e8ec4
downloadaur-685f8e54236bdd730f400d1c2b6154936951a7fc.tar.gz
initial import
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD43
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..439fc4491f15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = haskell-gi-gtk
+ pkgdesc = Bindings for Gtk, autogenerated by haskell-gi.
+ pkgver = 3.0.23
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/gi-gtk
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = ghc
+ depends = haskell-base
+ depends = ghc-libs
+ depends = haskell-bytestring
+ depends = haskell-containers
+ depends = haskell-gi-atk
+ depends = haskell-gi-cairo
+ depends = haskell-gi-gdk
+ depends = haskell-gi-gdkpixbuf
+ depends = haskell-gi-gio
+ depends = haskell-gi-glib
+ depends = haskell-gi-gobject
+ depends = haskell-gi-pango
+ depends = haskell-gi
+ depends = haskell-gi-base
+ depends = haskell-gi-overloading
+ depends = haskell-text
+ depends = haskell-transformers
+ source = https://hackage.haskell.org/packages/archive/gi-gtk/3.0.23/gi-gtk-3.0.23.tar.gz
+ sha256sums = 93e8211564ebd62e580ac8ce6c224c8e1f489965cd31cc2f6c193675d0443152
+
+pkgname = haskell-gi-gtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96f6877aa206
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-gtk
+_hkgname=gi-gtk
+pkgver=3.0.23
+pkgrel=1
+pkgdesc="Bindings for Gtk, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-gtk
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=('haskell-base' 'ghc-libs' 'haskell-bytestring'
+'haskell-containers' 'haskell-gi-atk' 'haskell-gi-cairo'
+'haskell-gi-gdk' 'haskell-gi-gdkpixbuf' 'haskell-gi-gio'
+'haskell-gi-glib' 'haskell-gi-gobject' 'haskell-gi-pango' 'haskell-gi'
+'haskell-gi-base' 'haskell-gi-overloading' 'haskell-text' 'haskell-transformers')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('93e8211564ebd62e580ac8ce6c224c8e1f489965cd31cc2f6c193675d0443152')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}