summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-08 23:19:31 -0400
committerSolomon Choina2018-06-08 23:19:31 -0400
commitdec8524785c452647d50b63e94ece6a1e5150262 (patch)
tree9687cdc01942a5b483fcc74dac8d3bf0a14f680b
downloadaur-dec8524785c452647d50b63e94ece6a1e5150262.tar.gz
initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD43
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f27c5be4512d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = haskell-gi-gtk-hs
+ pkgdesc = Bindings for Gtk, autogenerated by haskell-gi.
+ pkgver = 0.3.6.1
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/gi-gtk
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ makedepends = ghc
+ depends = haskell-base
+ depends = haskell-base-compat
+ depends = ghc-libs
+ depends = haskell-containers
+ depends = haskell-gi-gtk
+ depends = haskell-mtl
+ depends = haskell-gi-gdk
+ depends = haskell-gi-gdkpixbuf
+ depends = haskell-gi-glib
+ depends = haskell-gi-gobject
+ depends = haskell-gi-base
+ depends = haskell-text
+ depends = haskell-transformers
+ source = https://hackage.haskell.org/packages/archive/gi-gtk-hs/0.3.6.1/gi-gtk-hs-0.3.6.1.tar.gz
+ sha256sums = 9cb25b6585f20ab8593fd3ca544c0193d1c86d1e1bd8d8d43ae412f2c78b4161
+
+pkgname = haskell-gi-gtk-hs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0876aee2d39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-gtk-hs
+_hkgname=gi-gtk-hs
+pkgver=0.3.6.1
+pkgrel=1
+pkgdesc="Bindings for Gtk, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-gtk
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=('haskell-base' 'haskell-base-compat' 'ghc-libs'
+'haskell-containers' 'haskell-gi-gtk' 'haskell-mtl'
+'haskell-gi-gdk' 'haskell-gi-gdkpixbuf'
+'haskell-gi-glib' 'haskell-gi-gobject'
+'haskell-gi-base' 'haskell-text' 'haskell-transformers')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('9cb25b6585f20ab8593fd3ca544c0193d1c86d1e1bd8d8d43ae412f2c78b4161')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}