summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2016-06-29 14:34:12 -0400
committerCody P Schafer2016-06-29 14:34:12 -0400
commit5eda51c50a9190de2dda80c4e7e07330641b9864 (patch)
tree1c0dce00c04a3c0427a82bcd7a011334ddc63e9b
parentc03a37e9ec2fe44f1dbdba1a3123ef12ea6bd692 (diff)
downloadaur-5eda51c50a9190de2dda80c4e7e07330641b9864.tar.gz
take ownership, update version, update style to match in-tree haskell packages
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD45
-rw-r--r--haskell-gio.install18
4 files changed, 39 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fa24b133339..b1cb984ea6bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = haskell-gio
pkgdesc = Binding to the GIO.
- pkgver = 0.13.0.4
+ pkgver = 0.13.3.0
pkgrel = 1
url = http://hackage.haskell.org/package/gio
- install = haskell-gio.install
arch = i686
arch = x86_64
license = LGPL-2.1
+ makedepends = haskell-gtk2hs-buildtools
depends = ghc
depends = haskell-array
depends = haskell-bytestring
depends = haskell-containers
- depends = haskell-glib<0.13
- depends = haskell-glib>=0.12
+ depends = haskell-glib
depends = haskell-mtl
depends = glib2
- depends = gtk2hs-buildtools
- options = strip
- options = staticlibs
- source = http://hackage.haskell.org/packages/archive/gio/0.13.0.4/gio-0.13.0.4.tar.gz
- md5sums = c252802fc52c055691e303ca30e4563f
+ options = !emptydirs
+ source = http://hackage.haskell.org/packages/archive/gio/0.13.3.0/gio-0.13.3.0.tar.gz
+ md5sums = 8d3c4d06a275ab4e464de0e70128f44e
pkgname = haskell-gio
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index bcdb138bba8c..2894344e946d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,53 @@
+# Maintainer: Cody P Schafer <archlinux at codyps.com>
# Maintainer: Daniel Nagy <danielnagy at gmx de>
# Contributor: Martin Harvan <martinhrvn@gmail.com>
_hkgname=gio
-pkgname=haskell-gio
-pkgver=0.13.0.4
+pkgname=haskell-${_hkgname}
+pkgver=0.13.3.0
pkgrel=1
pkgdesc="Binding to the GIO."
url="http://hackage.haskell.org/package/${_hkgname}"
license=('LGPL-2.1')
arch=('i686' 'x86_64')
-makedepends=()
-depends=('ghc'
- 'haskell-array'
- 'haskell-bytestring'
- 'haskell-containers'
- 'haskell-glib<0.13' 'haskell-glib>=0.12'
- 'haskell-mtl'
- 'glib2'
- 'gtk2hs-buildtools')
-options=('strip' 'staticlibs')
+makedepends=('haskell-gtk2hs-buildtools')
+depends=('ghc'
+ 'haskell-array'
+ 'haskell-bytestring'
+ 'haskell-containers'
+ 'haskell-glib'
+ 'haskell-mtl'
+ 'glib2'
+)
+options=(!emptydirs)
source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
-install=${pkgname}.install
-md5sums=('c252802fc52c055691e303ca30e4563f')
+md5sums=('8d3c4d06a275ab4e464de0e70128f44e')
+
build() {
cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
--prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
+
+_update_deps() {
+ _ver=`pacman -Q $1 | cut -f2 -d\ | cut -f1 -d-`
+ for i in `seq 0 $(expr ${#depends[@]} - 1)`; do
+ if [ ${depends[$i]} == $1 ]; then
+ depends[$i]="$1=${_ver}"
+ fi
+ done
+}
+
package() {
+ _update_deps ghc
+ _update_deps haskell-mtl
+
cd ${srcdir}/${_hkgname}-${pkgver}
install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
diff --git a/haskell-gio.install b/haskell-gio.install
deleted file mode 100644
index 6461552d56a6..000000000000
--- a/haskell-gio.install
+++ /dev/null
@@ -1,18 +0,0 @@
-HS_DIR=usr/share/haskell/haskell-gio
-post_install() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_upgrade() {
- ${HS_DIR}/unregister.sh
-}
-post_upgrade() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_remove() {
- ${HS_DIR}/unregister.sh
-}
-post_remove() {
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}