summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:29:15 +0200
committerDaniel Nagy2015-06-08 20:29:15 +0200
commitc03a37e9ec2fe44f1dbdba1a3123ef12ea6bd692 (patch)
treec0ed59fe89c295328f393565f44c9e11bb3c0d9f
downloadaur-c03a37e9ec2fe44f1dbdba1a3123ef12ea6bd692.tar.gz
import to aur4
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
-rw-r--r--haskell-gio.install18
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0fa24b133339
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = haskell-gio
+ pkgdesc = Binding to the GIO.
+ pkgver = 0.13.0.4
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/gio
+ install = haskell-gio.install
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ depends = ghc
+ depends = haskell-array
+ depends = haskell-bytestring
+ depends = haskell-containers
+ depends = haskell-glib<0.13
+ depends = haskell-glib>=0.12
+ depends = haskell-mtl
+ depends = glib2
+ depends = gtk2hs-buildtools
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/gio/0.13.0.4/gio-0.13.0.4.tar.gz
+ md5sums = c252802fc52c055691e303ca30e4563f
+
+pkgname = haskell-gio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcdb138bba8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Martin Harvan <martinhrvn@gmail.com>
+
+_hkgname=gio
+pkgname=haskell-gio
+pkgver=0.13.0.4
+pkgrel=1
+pkgdesc="Binding to the GIO."
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc'
+ 'haskell-array'
+ 'haskell-bytestring'
+ 'haskell-containers'
+ 'haskell-glib<0.13' 'haskell-glib>=0.12'
+ 'haskell-mtl'
+ 'glib2'
+ 'gtk2hs-buildtools')
+options=('strip' 'staticlibs')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+md5sums=('c252802fc52c055691e303ca30e4563f')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+}
diff --git a/haskell-gio.install b/haskell-gio.install
new file mode 100644
index 000000000000..6461552d56a6
--- /dev/null
+++ b/haskell-gio.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-gio
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}