summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:29:18 +0200
committerDaniel Nagy2015-06-08 20:29:18 +0200
commit03ffbb6c79eeeec998ea0ce50f41ff1866453390 (patch)
tree7d445b72e32eb7249efa782b1ebb698fffecfa2e
downloadaur-03ffbb6c79eeeec998ea0ce50f41ff1866453390.tar.gz
import to aur4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-glfw.install18
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f9112e84164
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = haskell-glfw
+ pkgdesc = A Haskell binding for GLFW
+ pkgver = 0.5.2.2
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/GLFW
+ install = haskell-glfw.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-opengl=2.8.0.0
+ depends = libxrandr
+ depends = libx11
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/GLFW/0.5.2.2/GLFW-0.5.2.2.tar.gz
+ md5sums = 7c099890d70318dba41e08fb9c2e68f6
+
+pkgname = haskell-glfw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..009601bce670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+_hkgname=GLFW
+pkgname=haskell-glfw
+pkgver=0.5.2.2
+pkgrel=1
+pkgdesc="A Haskell binding for GLFW"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-opengl=2.8.0.0' 'libxrandr' 'libx11')
+options=('strip' 'staticlibs')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
+md5sums=('7c099890d70318dba41e08fb9c2e68f6')
diff --git a/haskell-glfw.install b/haskell-glfw.install
new file mode 100644
index 000000000000..a082663e300a
--- /dev/null
+++ b/haskell-glfw.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-glfw
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}