summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmanuel Amaral Couto2017-10-19 23:38:04 +0100
committerEmanuel Amaral Couto2017-10-19 23:44:39 +0100
commit6cb50f0e906da22d12de0ae13b894134554e271c (patch)
treecba53d1964d1732eb002517e834103dc36c344cc
parentee98e45ea9f4840c8f880768a1589a3cdfa36071 (diff)
downloadaur-6cb50f0e906da22d12de0ae13b894134554e271c.tar.gz
Bump version
While at it made the code consistent with other haskell packages.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD45
-rw-r--r--haskell-gluraw.install18
3 files changed, 30 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4a852f4f25a..ba434326f222 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = haskell-gluraw
pkgdesc = A raw binding for the OpenGL graphics system
- pkgver = 1.4.0.2
+ pkgver = 2.0.0.3
pkgrel = 1
url = http://hackage.haskell.org/package/GLURaw
- install = haskell-gluraw.install
arch = i686
arch = x86_64
license = custom:BSD3
- depends = ghc
- depends = haskell-openglraw>=1.3.0.0
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-openglraw>=3.0.0.0
depends = libgl
- options = strip
- source = http://hackage.haskell.org/packages/archive/GLURaw/1.4.0.2/GLURaw-1.4.0.2.tar.gz
- md5sums = e0a3f6ee10e6e4b1b0032af09e5b7ed4
+ source = https://hackage.haskell.org/packages/archive/GLURaw/2.0.0.3/GLURaw-2.0.0.3.tar.gz
+ sha512sums = dccd459c9392b1608d91cb80904346472209cb5dc8f2afbbb1ad07e24ddc0c8affc2eda4bb9aec9b2bc0e94e4546685cb60239c5687c629a8184b91162b4cc56
pkgname = haskell-gluraw
diff --git a/PKGBUILD b/PKGBUILD
index 9dcac966956a..d7bd4c3ac739 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,39 @@
-# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# $Id$
+# Maintainer: Emanuel Couto <unit73e at gmail dot com>
+# Contributor: Daniel Nagy <danielnagy at gmx de>
_hkgname=GLURaw
pkgname=haskell-gluraw
-pkgver=1.4.0.2
+pkgver=2.0.0.3
pkgrel=1
pkgdesc="A raw binding for the OpenGL graphics system"
url="http://hackage.haskell.org/package/${_hkgname}"
license=('custom:BSD3')
arch=('i686' 'x86_64')
-makedepends=()
-depends=('ghc' 'haskell-openglraw>=1.3.0.0' 'libgl')
-options=('strip')
-source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
-install=${pkgname}.install
-md5sums=('e0a3f6ee10e6e4b1b0032af09e5b7ed4')
+depends=('ghc-libs' 'haskell-openglraw>=3.0.0.0' 'libgl')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha512sums=('dccd459c9392b1608d91cb80904346472209cb5dc8f2afbbb1ad07e24ddc0c8affc2eda4bb9aec9b2bc0e94e4546685cb60239c5687c629a8184b91162b4cc56')
+
build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
- runhaskell Setup haddock
- runhaskell Setup register --gen-script
+ runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
-}
+}
+
package() {
cd ${srcdir}/${_hkgname}-${pkgver}
- install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
- install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}
diff --git a/haskell-gluraw.install b/haskell-gluraw.install
deleted file mode 100644
index 05e08fa2f8b7..000000000000
--- a/haskell-gluraw.install
+++ /dev/null
@@ -1,18 +0,0 @@
-HS_DIR=usr/share/haskell/haskell-gluraw
-post_install() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_upgrade() {
- ${HS_DIR}/unregister.sh
-}
-post_upgrade() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_remove() {
- ${HS_DIR}/unregister.sh
-}
-post_remove() {
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}