summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2016-06-29 13:46:30 -0400
committerCody P Schafer2016-06-29 13:46:30 -0400
commit9954c4c0ab2dcbbfd6ece63a051eb202d2307163 (patch)
tree5e1545ba23ab2694b2c1d14471d038b264695991
parente629de8c501ab5fd2c011b5668d290366b2f0cd7 (diff)
downloadaur-9954c4c0ab2dcbbfd6ece63a051eb202d2307163.tar.gz
tweak to hgettext
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f41683e7df92..c912cd2213c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
-pkgbase = haskell-pcap
- pkgdesc = A system-independent interface for user-level packet capture
- pkgver = 0.4.5.2
+pkgbase = haskell-hgettext
+ pkgdesc = bindings to libintl.h (gettext, bindtextdomain)
+ pkgver = 0.1.30
pkgrel = 1
- url = https://github.com/bos/pcap
+ url = https://github.com/vasylp/hgettext
arch = x86_64
license = custom:BSD3
makedepends = git
depends = ghc
- provides = haskell-pcap
- conflicts = haskell-pcap
+ depends = haskell-src-exts
+ depends = haskell-uniplate
+ provides = haskell-hgettext
+ conflicts = haskell-hgettext
options = !emptydirs
- source = http://hackage.haskell.org/packages/archive/pcap/0.4.5.2/pcap-0.4.5.2.tar.gz
- md5sums = 492b7ecc53d0ac3599845ab8ac553997
+ source = http://hackage.haskell.org/packages/archive/hgettext/0.1.30/hgettext-0.1.30.tar.gz
+ md5sums = 6b36a5c86e13de18c7daef124d9e9a71
-pkgname = haskell-pcap
+pkgname = haskell-hgettext
diff --git a/PKGBUILD b/PKGBUILD
index 82bf322a384f..954ee8bb39ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Cody P Schafer <archlinux at codyps.com>
-_ipn=pcap
+_ipn=hgettext
_bpn=haskell-${_ipn}
pkgname=${_bpn}
-pkgver=0.4.5.2
+pkgver=0.1.30
pkgrel=1
-pkgdesc="A system-independent interface for user-level packet capture"
+pkgdesc="bindings to libintl.h (gettext, bindtextdomain)"
arch=(x86_64)
-url="https://github.com/bos/pcap"
+url="https://github.com/vasylp/hgettext"
license=('custom:BSD3')
groups=()
-depends=(ghc)
+depends=(ghc haskell-src-exts haskell-uniplate)
makedepends=(git)
provides=(${_bpn})
conflicts=(${_bpn})
@@ -18,7 +18,7 @@ backup=()
options=(!emptydirs)
install=
source=("http://hackage.haskell.org/packages/archive/${_ipn}/${pkgver}/${_ipn}-${pkgver}.tar.gz")
-md5sums=('492b7ecc53d0ac3599845ab8ac553997')
+md5sums=('6b36a5c86e13de18c7daef124d9e9a71')
build() {
cd "$srcdir/${_ipn}-${pkgver}"
@@ -48,8 +48,6 @@ package() {
install -dm755 ${pkgdir}/usr/share/doc/ghc/html/libraries
ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_ipn}
runhaskell Setup copy --destdir=${pkgdir}
- install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
}
# vim:set ts=2 sw=2 et: