summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdriĆ  Arrufat2016-01-10 11:54:46 +0100
committerAdriĆ  Arrufat2016-01-10 11:54:46 +0100
commit6d13179543cd671c43c287610740a2020fa30941 (patch)
tree6dc1f59b893e46e5309ff658a01f4432b87513f1
parent47883eb43a6e9621cc018bf665de6a8479f9f147 (diff)
downloadaur-6d13179543cd671c43c287610740a2020fa30941.tar.gz
fixed dependencies
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD1
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95b8349cc2eb..fef12c67834e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jan 10 10:51:33 UTC 2016
+# Sun Jan 10 10:54:29 UTC 2016
pkgbase = haskell-hmatrix
pkgdesc = Linear systems, matrix decompositions, and other numerical computations based on BLAS and LAPACK
pkgver = 0.17.0.1
@@ -22,5 +22,11 @@ pkgbase = haskell-hmatrix
md5sums = a4d356f6cdc5d7b03fc1c280fe5bfb66
pkgname = haskell-hmatrix
- depends = ghc=
+ depends = ghc
+ depends = haskell-random
+ depends = haskell-split
+ depends = haskell-storable-complex
+ depends = haskell-vector
+ depends = lapack
+ depends = blas
diff --git a/PKGBUILD b/PKGBUILD
index bcdc0df39847..629032c9c8dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,6 +31,7 @@ build() {
package() {
_ghcver=`pacman -Q ghc | cut -f2 -d\ | cut -f1 -d-`
depends=("ghc=${_ghcver}")
+ depends=("ghc" "haskell-random" "haskell-split" "haskell-storable-complex" "haskell-vector" "lapack" "blas")
cd ${srcdir}/hmatrix-${pkgver}
install -Dm744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh