summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-04-09 23:06:35 +0200
committerJose Riha2021-04-09 23:06:35 +0200
commit51c785ce76196fa9f0b298839d6b69b601affc71 (patch)
tree0538f1c3dc1dc96aafb4e7a3a6c343bb2c13780f
parent945a303a1c606d9bc35bd4badb22201a0fe61a80 (diff)
downloadaur-haskell-hsemail.tar.gz
Update and fix build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf2191195a97..d06c476dd63d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = haskell-hsemail
pkgdesc = Internet Message Parsers
- pkgver = 1.7.7
+ pkgver = 2.2.1
pkgrel = 1
url = http://hackage.haskell.org/package/hsemail
install = haskell-hsemail.install
@@ -14,8 +14,8 @@ pkgbase = haskell-hsemail
depends = haskell-old-time
depends = haskell-parsec
options = strip
- source = http://hackage.haskell.org/packages/archive/hsemail/1.7.7/hsemail-1.7.7.tar.gz
- sha256sums = 25aac3890ff09812be47639ad52cd7be622dc9b193e5a0be115bda12ffcd989b
+ source = http://hackage.haskell.org/packages/archive/hsemail/2.2.1/hsemail-2.2.1.tar.gz
+ sha256sums = b5ea99b4d98c988f1ca248a5641e3ecbe22b200cfcecfd1011fdaa93af961d81
pkgname = haskell-hsemail
diff --git a/PKGBUILD b/PKGBUILD
index 429db324b39b..c718a9c5c95d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_hkgname=hsemail
pkgname=haskell-hsemail
-pkgver=1.7.7
+pkgver=2.2.1
pkgrel=1
pkgdesc="Internet Message Parsers"
url="http://hackage.haskell.org/package/$_hkgname"
@@ -14,15 +14,14 @@ depends=("haskell-base" "sh" "haskell-mtl" "haskell-old-time" "haskell-parsec")
options=('strip')
source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
install="${pkgname}.install"
-sha256sums=("25aac3890ff09812be47639ad52cd7be622dc9b193e5a0be115bda12ffcd989b")
+sha256sums=('b5ea99b4d98c988f1ca248a5641e3ecbe22b200cfcecfd1011fdaa93af961d81')
# PKGBUILD functions
build() {
cd ${srcdir}/${_hkgname}-${pkgver}
-
- runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
- --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic \
+ --disable-library-vanilla --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
runhaskell Setup register --gen-script