summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2023-06-27 21:07:38 +0200
committerMichał Wojdyła2023-06-27 21:07:38 +0200
commit08322e9fc023bb75193759139de566f376a7a370 (patch)
tree0eb816b0c4de896b0d049d099f26a06d02e298fa
parentf13450e03efd6eff02207a656fcde68928815bdf (diff)
downloadaur-haskell-hsh.tar.gz
update to 2.1.3
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD43
-rw-r--r--directory.patch14
-rw-r--r--haskell-hsh.install18
-rw-r--r--orphans.patch11
-rw-r--r--process.patch34
6 files changed, 27 insertions, 125 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6049c284ec9..6842f1ca542e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,16 @@
-# Generated by mksrcinfo v8
-# Sat Aug 20 19:57:48 UTC 2016
pkgbase = haskell-hsh
pkgdesc = Library to mix shell scripting with Haskell programs
- pkgver = 2.1.2
+ pkgver = 2.1.3
pkgrel = 1
url = http://hackage.haskell.org/package/HSH
- install = haskell-hsh.install
arch = i686
arch = x86_64
license = LGPL
- depends = ghc
- depends = haskell-missingh>=1.0.0
- depends = haskell-bytestring>=0.9.1.10
- depends = haskell-directory>=1.1.0.0
- depends = haskell-filepath>=1.2.0.0
- depends = haskell-hslogger
- depends = haskell-mtl>=2.0.1.0
- depends = haskell-process>=1.0.1.5
- depends = haskell-regex-base>=0.93.2
- depends = haskell-regex-compat>=0.93.1
- depends = haskell-regex-posix>=0.94.4
- depends = haskell-unix>=2.4.2.0
- depends = haskell-base<5
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-missingh
options = strip
- source = http://hackage.haskell.org/packages/archive/HSH/2.1.2/HSH-2.1.2.tar.gz
- source = directory.patch
- source = orphans.patch
- source = process.patch
- sha256sums = 788a7f25336e7fe9c7d38b68bb4cc0030712fc47e0cdf282267dea1e46b0da9f
- sha256sums = 78f32f4e3109ef478d33135624940484eaa3c269f80e3ec602ba0c2864ff0354
- sha256sums = 819c1dae6ebcc5ff89115c87c48bb4ba6cb3f4b4f91ca5a08455487007ea6dee
- sha256sums = 325b18dd5c81da298f3afa976e8488e4edab14a1c9e5e23f577a4412f6693e34
+ source = http://hackage.haskell.org/packages/archive/HSH/2.1.3/HSH-2.1.3.tar.gz
+ sha256sums = 54df051277d3dfe263277e2c2416ecb5f1515bc69729870f13749b495565670d
pkgname = haskell-hsh
-
diff --git a/PKGBUILD b/PKGBUILD
index deede3ed0864..29ac4e9e3cd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,38 @@
-# Maintainer: João Miguel <jmcf125 at openmailbox dot org>
+# Contributor: João Miguel <jmcf125 at openmailbox dot org>
# (with the help of cabal2arch ;-)
_hkgname=HSH
pkgname=haskell-hsh
-pkgver=2.1.2
+pkgver=2.1.3
pkgrel=1
pkgdesc="Library to mix shell scripting with Haskell programs"
url="http://hackage.haskell.org/package/${_hkgname}"
license=('LGPL')
arch=('i686' 'x86_64')
-makedepends=()
-depends=('ghc' 'haskell-missingh>=1.0.0' 'haskell-bytestring>=0.9.1.10' 'haskell-directory>=1.1.0.0' 'haskell-filepath>=1.2.0.0' 'haskell-hslogger' 'haskell-mtl>=2.0.1.0' 'haskell-process>=1.0.1.5' 'haskell-regex-base>=0.93.2' 'haskell-regex-compat>=0.93.1' 'haskell-regex-posix>=0.94.4' 'haskell-unix>=2.4.2.0' 'haskell-base<5')
+makedepends=('ghc')
+depends=('ghc-libs' 'haskell-missingh')
options=('strip')
-source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz directory.patch orphans.patch process.patch)
-install=${pkgname}.install
-sha256sums=(788a7f25336e7fe9c7d38b68bb4cc0030712fc47e0cdf282267dea1e46b0da9f 78f32f4e3109ef478d33135624940484eaa3c269f80e3ec602ba0c2864ff0354 819c1dae6ebcc5ff89115c87c48bb4ba6cb3f4b4f91ca5a08455487007ea6dee 325b18dd5c81da298f3afa976e8488e4edab14a1c9e5e23f577a4412f6693e34)
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+sha256sums=('54df051277d3dfe263277e2c2416ecb5f1515bc69729870f13749b495565670d')
build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- # Yes, 3 patches, 3 different problems, 3 files
- patch -p2 -i "$srcdir/directory.patch" # needed since System.Directory 1.2.6
- patch -p2 -i "$srcdir/process.patch" # needed since System.Process 1.3.0
- patch -p2 -i "$srcdir/orphans.patch"
- # \---> part of the point of HSH is having all those orphan instances (also, an open world assumption is implied), those specific warnings are just noise
- runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
- runhaskell Setup register --gen-script
+ runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
+
package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
- install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
- install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
- ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
- runhaskell Setup copy --destdir=${pkgdir}
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/COPYING"
}
diff --git a/directory.patch b/directory.patch
deleted file mode 100644
index 52cab104ebf4..000000000000
--- a/directory.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/HSH-2.1.2/HSH/ShellEquivs.hs 2014-10-28 13:00:59.000000000 +0000
-+++ ShellEquivs.hs 2016-08-20 14:12:53.229915254 +0100
-@@ -86,7 +86,11 @@
- import Text.Regex (matchRegex, mkRegex)
- import Text.Printf (printf)
- import Control.Monad (foldM)
-+#if __GLASGOW_HASKELL__>=800 || MIN_VERSION_directory(1,2,6)
-+import System.Directory hiding (createDirectory,isSymbolicLink) -- SD.isSymbolicLink é novo
-+#else
- import System.Directory hiding (createDirectory)
-+#endif
- import qualified Control.Exception as E
- -- import System.FilePath (splitPath)
-
diff --git a/haskell-hsh.install b/haskell-hsh.install
deleted file mode 100644
index 73a1dcaf42a1..000000000000
--- a/haskell-hsh.install
+++ /dev/null
@@ -1,18 +0,0 @@
-HS_DIR=usr/share/haskell/haskell-hsh
-post_install() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_upgrade() {
- ${HS_DIR}/unregister.sh
-}
-post_upgrade() {
- ${HS_DIR}/register.sh
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-pre_remove() {
- ${HS_DIR}/unregister.sh
-}
-post_remove() {
- (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
diff --git a/orphans.patch b/orphans.patch
deleted file mode 100644
index e9319e5e2f01..000000000000
--- a/orphans.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/HSH-2.1.2/HSH.cabal 2014-10-28 13:00:59.000000000 +0000
-+++ HSH.cabal 2016-08-20 20:40:16.529988440 +0100
-@@ -32,7 +32,7 @@
- bytestring
- if !os(windows)
- Build-Depends: unix
-- GHC-Options: -O2 -threaded -Wall
-+ GHC-Options: -O2 -threaded -Wall -Wno-orphans
-
- Executable runtests
- if flag(buildtests)
diff --git a/process.patch b/process.patch
deleted file mode 100644
index c590c3e9901a..000000000000
--- a/process.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/HSH-2.1.2/HSH/Command.hs 2014-10-28 13:00:59.000000000 +0000
-+++ Command.hs 2016-08-20 14:48:31.149988715 +0100
-@@ -301,6 +301,15 @@
- #if MIN_VERSION_process(1,2,0)
- , delegate_ctlc = False
- #endif
-+#if MIN_VERSION_process(1,3,0)
-+ , detach_console = False
-+ , create_new_console = False
-+ , new_session = False
-+#endif
-+#if MIN_VERSION_process(1,4,0)
-+ , child_group = Nothing
-+ , child_user = Nothing
-+#endif
- }
- in do (_, oh', _, ph) <- createProcess cp
- let oh = fromJust oh'
-@@ -320,6 +329,15 @@
- #if MIN_VERSION_process(1,2,0)
- , delegate_ctlc = False
- #endif
-+#if MIN_VERSION_process(1,3,0)
-+ , detach_console = False
-+ , create_new_console = False
-+ , new_session = False
-+#endif
-+#if MIN_VERSION_process(1,4,0)
-+ , child_group = Nothing
-+ , child_user = Nothing
-+#endif
- }
- in do (ih', oh', _, ph) <- createProcess cp
- let ih = fromJust ih'