summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:30:06 +0200
committerDaniel Nagy2015-06-08 20:30:06 +0200
commit01fc15478a245c39c7a73257bae1d75c01b99231 (patch)
treea2b6862a6b219de84fc10bd882e26529700dcbe2
downloadaur-01fc15478a245c39c7a73257bae1d75c01b99231.tar.gz
import to aur4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD48
-rw-r--r--haskell-hssyck.install26
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..104fb0e293c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = haskell-hssyck
+ pkgdesc = Fast, lightweight YAML loader and dumper
+ pkgver = 0.52
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/HsSyck
+ install = haskell-hssyck.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-syb
+ depends = haskell-hashtables
+ depends = haskell-utf8-string
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/HsSyck/0.52/HsSyck-0.52.tar.gz
+ sha256sums = 6c73bcbf8dee55e8a76a8dc9835201a2f995fe1c5c67f255f3f55f60ea9aacc1
+
+pkgname = haskell-hssyck
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d3accbaee35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+# custom variables
+_hkgname=HsSyck
+_licensefile=LICENSE
+
+# PKGBUILD options/directives
+pkgname=haskell-hssyck
+pkgver=0.52
+pkgrel=1
+pkgdesc="Fast, lightweight YAML loader and dumper"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=("custom:BSD3")
+arch=('i686' 'x86_64')
+makedepends=()
+depends=("ghc"
+ "haskell-syb"
+ "haskell-hashtables"
+ "haskell-utf8-string")
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+install=$pkgname.install
+options=('strip' 'staticlibs')
+sha256sums=('6c73bcbf8dee55e8a76a8dc9835201a2f995fe1c5c67f255f3f55f60ea9aacc1')
+
+# PKGBUILD functions
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+
+ runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 ${_licensefile} ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/${_licensefile}
+}
diff --git a/haskell-hssyck.install b/haskell-hssyck.install
new file mode 100644
index 000000000000..f4215b1d89ab
--- /dev/null
+++ b/haskell-hssyck.install
@@ -0,0 +1,26 @@
+# custom variables
+pkgname=haskell-hssyck
+HS_DIR=usr/share/haskell/${pkgname}
+
+# functions
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}