summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeif Warner2018-01-27 02:07:16 -0800
committerLeif Warner2018-01-27 02:07:16 -0800
commit780f913ecf8fb53f464df79ce1e6b08d06ad3a90 (patch)
treea9f5d236cea6d62f37e5f881fc679722cf06ac02
downloadaur-780f913ecf8fb53f464df79ce1e6b08d06ad3a90.tar.gz
Initial commit v0.8.6
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD50
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93f84b9e1190
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Sat Jan 27 10:06:56 UTC 2018
+pkgbase = haskell-hstringtemplate
+ pkgdesc = StringTemplate implementation in Haskell.
+ pkgver = 0.8.6
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/HStringTemplate
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ depends = ghc
+ depends = haskell-blaze-builder
+ depends = haskell-mtl
+ depends = haskell-old-locale
+ depends = haskell-parsec
+ depends = haskell-syb
+ depends = haskell-text
+ depends = haskell-void
+ source = http://hackage.haskell.org/packages/archive/HStringTemplate/0.8.6/HStringTemplate-0.8.6.tar.gz
+ sha256sums = 7022cb9c1e1c223cfb8adf5ca6994b9f4709399ae197cb7541247c0b5d0255cd
+
+pkgname = haskell-hstringtemplate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5224ec6a0484
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Leif Warner <abimelech@gmail.com>
+
+# custom variables
+_hkgname=HStringTemplate
+
+# PKGBUILD options/directives
+pkgname=haskell-hstringtemplate
+pkgver=0.8.6
+pkgrel=1
+license=(BSD3)
+pkgdesc="StringTemplate implementation in Haskell."
+url="http://hackage.haskell.org/package/${_hkgname}"
+arch=('i686' 'x86_64')
+depends=("ghc"
+ "haskell-blaze-builder"
+ "haskell-mtl"
+ "haskell-old-locale"
+ "haskell-parsec"
+ "haskell-syb"
+ "haskell-text"
+ "haskell-void")
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+
+sha256sums=("7022cb9c1e1c223cfb8adf5ca6994b9f4709399ae197cb7541247c0b5d0255cd")
+
+# PKGBUILD functions
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}