summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-12-18 18:56:40 +0100
committerXiretza2020-12-18 18:56:40 +0100
commite80ad43c032c2e7120fe786bd461469e0901f351 (patch)
treeee9962d4da1b2b2334aeda940b1fae084657ece4
downloadaur-e80ad43c032c2e7120fe786bd461469e0901f351.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f01e2fd9fb81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haskell-indexed-list-literals
+ pkgver = 0.2.1.3
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/
+ arch = x86_64
+ license = BSD
+ makedepends = ghc
+ makedepends = haskell-hspec
+ depends = ghc-libs
+ depends = haskell-only
+ source = https://hackage.haskell.org/packages/archive/indexed-list-literals/0.2.1.3/indexed-list-literals-0.2.1.3.tar.gz
+ sha256sums = 26e399e285ddf44822781559f7202ed821382457ed6c1c32bdaac7945c033f9d
+
+pkgname = haskell-indexed-list-literals
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e131e4a7d6ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+_hkgname=indexed-list-literals
+pkgname=haskell-indexed-list-literals
+pkgver=0.2.1.3
+pkgrel=1
+license=('BSD')
+arch=('x86_64')
+url="https://hackage.haskell.org/package/$hkgname"
+depends=(ghc-libs haskell-only)
+makedepends=(ghc haskell-hspec)
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
+sha256sums=('26e399e285ddf44822781559f7202ed821382457ed6c1c32bdaac7945c033f9d')
+
+build() {
+ cd "$_hkgname-$pkgver"
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/$pkgname" --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build $MAKEFLAGS
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+check() {
+ cd "$_hkgname-$pkgver"
+ runhaskell Setup test
+}
+
+package() {
+ cd "$_hkgname-$pkgver"
+
+ install -D -m744 register.sh "$pkgdir/usr/share/haskell/register/$pkgname.sh"
+ install -D -m744 unregister.sh "$pkgdir/usr/share/haskell/unregister/$pkgname.sh"
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}