summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaron Kent-Dobias2019-02-06 16:26:55 -0500
committerJaron Kent-Dobias2019-02-06 16:26:55 -0500
commita64ee538ef6ae19fb9e775ab38bf89317d21eeb6 (patch)
treef3072c66fc5bec48e2e075c36f6f768df3acf2c2
downloadaur-a64ee538ef6ae19fb9e775ab38bf89317d21eeb6.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07cb46ec3c30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haskell-intervals
+ pkgdesc = Library for closed, convex sets of floating point values.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/intervals
+ arch = x86_64
+ license = BSD-3
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-distributive
+ source = https://hackage.haskell.org/package/intervals-0.8.1/intervals-0.8.1.tar.gz
+ sha512sums = ee6fe3efb3aae4569cfc33c1a2f3e0fdfb87d1a76258cb15c5aaaf1d4a88e304bfa8c439c536baccb4f230777668e54aafdf7bc951e17b6c3f281a1de241f395
+
+pkgname = haskell-intervals
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc3c190f0c8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+
+_hkgname=intervals
+pkgname=haskell-intervals
+pkgver=0.8.1
+pkgrel=1
+pkgdesc='Library for closed, convex sets of floating point values.'
+url='https://hackage.haskell.org/package/intervals'
+license=('BSD-3')
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-distributive')
+makedepends=('ghc')
+source=(https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+sha512sums=('ee6fe3efb3aae4569cfc33c1a2f3e0fdfb87d1a76258cb15c5aaaf1d4a88e304bfa8c439c536baccb4f230777668e54aafdf7bc951e17b6c3f281a1de241f395')
+
+build() {
+ cd ${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -dm 755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 CHANGELOG.markdown README.markdown -t "${pkgdir}/usr/share/doc/${pkgname}"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+}
+
+# vim: ts=2 sw=2 et: