summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2017-11-11 20:47:31 +0100
committerAlbert Graef2017-11-11 20:47:31 +0100
commit8017245b4f2a33ff34e52a61e7138ce9a66a7559 (patch)
treeac03b3de7a26230f68bf178bf7da8122c1ce6ad8
downloadaur-8017245b4f2a33ff34e52a61e7138ce9a66a7559.tar.gz
Initial upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caf0498b81f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Nov 11 19:43:50 UTC 2017
+pkgbase = haskell-language-c5
+ pkgdesc = Analysis and generation of C code
+ pkgver = 0.5.0
+ pkgrel = 2
+ url = http://visq.github.io/language-c/
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ makedepends = happy
+ makedepends = alex
+ depends = ghc
+ depends = haskell-syb
+ provides = haskell-language-c
+ conflicts = haskell-language-c
+ source = http://hackage.haskell.org/packages/archive/language-c/0.5.0/language-c-0.5.0.tar.gz
+ sha256sums = 86d58bc017a7bba157fc4d5d0ab9e3a3d3f3a2f98bfe46b5b0d5d72a0f5d2222
+
+pkgname = haskell-language-c5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6caf27f1a4a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Albert Graef <aggraef@gmail.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+# Old 0.5 language-c version, required for pure-gen package.
+
+_hkgname=language-c
+pkgname=haskell-language-c5
+pkgver=0.5.0
+pkgrel=2
+pkgdesc="Analysis and generation of C code"
+url="http://visq.github.io/language-c/"
+license=("custom:BSD3")
+arch=('i686' 'x86_64')
+makedepends=('happy' 'alex')
+depends=("ghc" "haskell-syb")
+provides=('haskell-language-c')
+conflicts=('haskell-language-c')
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('86d58bc017a7bba157fc4d5d0ab9e3a3d3f3a2f98bfe46b5b0d5d72a0f5d2222')
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ rm -fr dist
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --libsubdir=\$compiler/site-local/\$pkgid \
+ -fseparatesyb -fusebytestrings -fsplitbase
+ runhaskell Setup build
+ runhaskell Setup haddock --hoogle --html
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s "/usr/share/doc/${pkgname}/html" "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}