summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoscat2020-02-06 18:52:20 +0800
committerPoscat2020-02-06 18:52:20 +0800
commita521cb763da4710bf589c554b69643ced1c38339 (patch)
treee02488e64de34b3380c4439764463640b7bc0d7e
downloadaur-a521cb763da4710bf589c554b69643ced1c38339.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9451726c9288
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haskell-language-server-git
+ pkgdesc = Integration point for ghcide and haskell-ide-engine.
+ pkgver = r63.d1a232f
+ pkgrel = 1
+ url = https://github.com/haskell/haskell-language-server
+ arch = x86_64
+ arch = aarch64
+ license = Apache
+ makedepends = stack
+ makedepends = git
+ source = haskell-language-server-git::git+https://github.com/haskell/haskell-language-server.git
+ md5sums = SKIP
+
+pkgname = haskell-language-server-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..241b5a40eed6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Poscat <poscat@mail.poscat.moe>
+
+pkgname=haskell-language-server-git
+pkgver=r63.d1a232f
+pkgrel=1
+pkgdesc="Integration point for ghcide and haskell-ide-engine."
+arch=('x86_64' 'aarch64')
+url="https://github.com/haskell/haskell-language-server"
+license=('Apache')
+makedepends=('stack' 'git')
+source=(${pkgname}::git+https://github.com/haskell/haskell-language-server.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ stack build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ stack --local-bin-path "${pkgdir}/usr/bin/" install
+}