summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryardenac2013-05-09 16:26:14 -0700
committeryardenac2013-05-09 16:26:14 -0700
commitd7b23828099faa21a78af235620ae3316f32303e (patch)
tree1b92120daf5a79437f1cf9e6d44e4f43a5a8dc42
downloadaur-d7b23828099faa21a78af235620ae3316f32303e.tar.gz
make subdir for packages
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD37
-rw-r--r--haskell-largeword.install26
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8308984cd5dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = haskell-largeword
+ pkgdesc = Provides Word128, Word192 and Word256 and a way of producing other large words if required.
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = http://trac.haskell.org/largeword/wiki
+ install = haskell-largeword.install
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ makedepends = ghc
+ depends = haskell-base
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/largeword/1.0.4/largeword-1.0.4.tar.gz
+ sha256sums = 858a257890c698eaad065c6eced696be83b9e8288c1b081d6c7debbad6fad9a6
+
+pkgname = haskell-largeword
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ead3eb2081ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=haskell-largeword
+_hkgname=largeword
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Provides Word128, Word192 and Word256 and a way of producing other large words if required."
+url="http://trac.haskell.org/largeword/wiki"
+license=('BSD3')
+arch=('i686' 'x86_64')
+makedepends=('ghc')
+depends=('haskell-base')
+options=('strip')
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('858a257890c698eaad065c6eced696be83b9e8288c1b081d6c7debbad6fad9a6')
+install="${pkgname}.install"
+
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+
+}
diff --git a/haskell-largeword.install b/haskell-largeword.install
new file mode 100644
index 000000000000..3c36c00bb05f
--- /dev/null
+++ b/haskell-largeword.install
@@ -0,0 +1,26 @@
+# custom variables
+pkgname=haskell-largeword
+HS_DIR=/usr/share/haskell/${pkgname}
+
+# functions
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_remove() {
+ (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}