summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoscat2019-12-31 21:59:27 +0800
committerPoscat2019-12-31 21:59:27 +0800
commit90ea0f858409650451b90c8f4544c86c2a6cdf8f (patch)
treed1ade07a14bd4b6f5c5cc02a6cfbb0bcc8c7f700
parentfaaa33a0999f78d5ba765b698b070dacc0a1d5bf (diff)
downloadaur-90ea0f858409650451b90c8f4544c86c2a6cdf8f.tar.gz
Patch cabal file to make it compile
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--cabal.patch11
3 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28742f9ab151..7836dcfab505 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = haskell-latex-formulae-hakyll
pkgdesc = A library for rendering LaTeX formulae as images using an actual LaTeX installation
pkgver = 0.2.0.4
- pkgrel = 2
+ pkgrel = 3
url = https://hackage.haskell.org/package/latex-formulae-hakyll
arch = x86_64
arch = i686
@@ -17,7 +17,7 @@ pkgbase = haskell-latex-formulae-hakyll
source = haskell-latex-formulae-hakyll-0.2.0.4.tar.gz::https://hackage.haskell.org/packages/archive/latex-formulae-hakyll/0.2.0.4/latex-formulae-hakyll-0.2.0.4.tar.gz
source = cabal.patch
sha256sums = ae300d1e29d392f88961719b3a2429c14a2337295d2f9b47cc6850ccd8b82660
- sha256sums = 4a9bf875694bbfb7dd5e2aed61bc07b3da7d7c1f4d29bf3537e40ca432f03b2b
+ sha256sums = 12b64eb7615215262a14474f0039c35c5de469ed54252654dd2aa0efd5adc111
pkgname = haskell-latex-formulae-hakyll
diff --git a/PKGBUILD b/PKGBUILD
index 12c5cbdcf4e8..c6875944e279 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=haskell-latex-formulae-hakyll
_hkgname=latex-formulae-hakyll
pkgver=0.2.0.4
-pkgrel=2
+pkgrel=3
pkgdesc="A library for rendering LaTeX formulae as images using an actual LaTeX installation"
url="https://hackage.haskell.org/package/latex-formulae-hakyll"
license=('BSD')
@@ -16,7 +16,7 @@ makedepends=('ghc')
source=(${pkgname}-${pkgver}.tar.gz::"https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz"
cabal.patch)
sha256sums=('ae300d1e29d392f88961719b3a2429c14a2337295d2f9b47cc6850ccd8b82660'
- '4a9bf875694bbfb7dd5e2aed61bc07b3da7d7c1f4d29bf3537e40ca432f03b2b')
+ '12b64eb7615215262a14474f0039c35c5de469ed54252654dd2aa0efd5adc111')
prepare() {
cd ${_hkgname}-${pkgver}
diff --git a/cabal.patch b/cabal.patch
index 39cfc5fddb9e..1e8730e93732 100644
--- a/cabal.patch
+++ b/cabal.patch
@@ -1,13 +1,18 @@
diff --git a/latex-formulae-hakyll.cabal b/latex-formulae-hakyll.cabal
-index 52db8c7..393a1bc 100644
+index 52db8c7..6cb3c86 100644
--- a/latex-formulae-hakyll.cabal
+++ b/latex-formulae-hakyll.cabal
-@@ -26,7 +26,7 @@ library
+@@ -26,11 +26,11 @@ library
exposed-modules: Hakyll.Contrib.LaTeX
-- other-modules:
-- other-extensions:
- build-depends: base >=4.7 && <4.12
-+ build-depends: base >=4.7 && <5
++ build-depends: base >=4.7 && <5
, latex-formulae-image >= 0.1.1.0 && < 0.2
, latex-formulae-pandoc >= 0.2.0.1 && < 0.3
, hakyll >= 4.6 && < 4.13
+- , pandoc-types >= 1.12 && < 1.18
++ , pandoc-types >= 1.12
+ , lrucache >= 1.2 && <1.3
+ hs-source-dirs: src
+ default-language: Haskell2010