summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoscat2019-11-30 16:02:25 +0800
committerPoscat2019-11-30 16:02:25 +0800
commitd1c69b6701b2b5af71d89cf76f705ef80b33acbc (patch)
treedd278de2664f448363874d479923f6f83bb740cd
downloadaur-d1c69b6701b2b5af71d89cf76f705ef80b33acbc.tar.gz
Initial-commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD50
-rw-r--r--cabal.patch13
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fb9eddf8fe5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = haskell-latex-formulae-hakyll
+ pkgdesc = A library for rendering LaTeX formulae as images using an actual LaTeX installation
+ pkgver = 0.2.0.4
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/latex-formulae-hakyll
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = BSD
+ makedepends = ghc
+ makedepends = haskell-hakyll
+ makedepends = haskell-latex-formulae-image
+ makedepends = haskell-latex-formulae-pandoc
+ makedepends = haskell-lrucache
+ makedepends = haskell-pandoc-types
+ depends = ghc-libs
+ depends = haskell-hakyll
+ depends = haskell-latex-formulae-image
+ depends = haskell-latex-formulae-pandoc
+ depends = haskell-lrucache
+ depends = haskell-pandoc-types
+ source = haskell-latex-formulae-hakyll-0.2.0.4.tar.gz::https://hackage.haskell.org/packages/archive/latex-formulae-hakyll/0.2.0.4/latex-formulae-hakyll-0.2.0.4.tar.gz
+ source = cabal.patch
+ sha256sums = ae300d1e29d392f88961719b3a2429c14a2337295d2f9b47cc6850ccd8b82660
+ sha256sums = 4a9bf875694bbfb7dd5e2aed61bc07b3da7d7c1f4d29bf3537e40ca432f03b2b
+
+pkgname = haskell-latex-formulae-hakyll
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..765d08ff006a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+pkgname=haskell-latex-formulae-hakyll
+_hkgname=latex-formulae-hakyll
+pkgver=0.2.0.4
+pkgrel=1
+pkgdesc="A library for rendering LaTeX formulae as images using an actual LaTeX installation"
+url="https://hackage.haskell.org/package/latex-formulae-hakyll"
+license=('BSD')
+arch=('x86_64' 'i686' 'aarch64')
+depends=('ghc-libs'
+ 'haskell-hakyll'
+ 'haskell-latex-formulae-image'
+ 'haskell-latex-formulae-pandoc'
+ 'haskell-lrucache'
+ 'haskell-pandoc-types')
+makedepends=('ghc'
+ 'haskell-hakyll'
+ 'haskell-latex-formulae-image'
+ 'haskell-latex-formulae-pandoc'
+ 'haskell-lrucache'
+ 'haskell-pandoc-types')
+source=(${pkgname}-${pkgver}.tar.gz::"https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz"
+ cabal.patch)
+sha256sums=('ae300d1e29d392f88961719b3a2429c14a2337295d2f9b47cc6850ccd8b82660'
+ '4a9bf875694bbfb7dd5e2aed61bc07b3da7d7c1f4d29bf3537e40ca432f03b2b')
+
+prepare() {
+ cd ${_hkgname}-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}/cabal.patch"
+}
+
+build() {
+ cd ${_hkgname}-${pkgver}
+ runghc Setup.hs configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runghc Setup.hs build
+ runghc Setup.hs register --gen-script
+ runghc Setup.hs unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ runghc Setup.hs copy --destdir="${pkgdir}"
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ mv "${pkgdir}/usr/share/doc/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+}
diff --git a/cabal.patch b/cabal.patch
new file mode 100644
index 000000000000..39cfc5fddb9e
--- /dev/null
+++ b/cabal.patch
@@ -0,0 +1,13 @@
+diff --git a/latex-formulae-hakyll.cabal b/latex-formulae-hakyll.cabal
+index 52db8c7..393a1bc 100644
+--- a/latex-formulae-hakyll.cabal
++++ b/latex-formulae-hakyll.cabal
+@@ -26,7 +26,7 @@ library
+ exposed-modules: Hakyll.Contrib.LaTeX
+ -- other-modules:
+ -- other-extensions:
+- build-depends: base >=4.7 && <4.12
++ build-depends: base >=4.7 && <5
+ , latex-formulae-image >= 0.1.1.0 && < 0.2
+ , latex-formulae-pandoc >= 0.2.0.1 && < 0.3
+ , hakyll >= 4.6 && < 4.13