summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoscat2019-11-30 15:08:35 +0800
committerPoscat2019-11-30 15:08:35 +0800
commited174e7d69765862653bd3b05df217dc1120e5e2 (patch)
tree43795fea0ad566765bcea8dd9819dd97b56157ed
downloadaur-ed174e7d69765862653bd3b05df217dc1120e5e2.tar.gz
Initial-commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD40
-rw-r--r--cabal.patch13
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4e1e94150cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = haskell-latex-formulae-image
+ pkgdesc = A library for rendering LaTeX formulae as images using an actual LaTeX installation
+ pkgver = 0.1.1.4
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/latex-formulae-hakyll
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = BSD
+ makedepends = ghc
+ makedepends = haskell-errors
+ makedepends = haskell-transformers-compat
+ makedepends = haskell-transformers-base
+ makedepends = haskell-juicypixels
+ depends = ghc-libs
+ depends = haskell-errors
+ depends = haskell-transformers-compat
+ depends = haskell-transformers-base
+ depends = haskell-juicypixels
+ source = haskell-latex-formulae-image-0.1.1.4.tar.gz::https://hackage.haskell.org/packages/archive/latex-formulae-image/0.1.1.4/latex-formulae-image-0.1.1.4.tar.gz
+ source = cabal.patch
+ sha256sums = 60b706f55f6cbfc8ef73eecf089a1d59ff939ac8a2c8f208af8f96211a067968
+ sha256sums = 1a791e369c47f6f438c9db40151ab65a69e22af801c07f8645f82b86f0b6642b
+
+pkgname = haskell-latex-formulae-image
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47b9f5c472f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=haskell-latex-formulae-image
+_hkgname=latex-formulae-image
+pkgver=0.1.1.4
+pkgrel=1
+pkgdesc="A library for rendering LaTeX formulae as images using an actual LaTeX installation"
+url="https://hackage.haskell.org/package/latex-formulae-hakyll"
+license=('BSD')
+arch=('x86_64' 'i686' 'aarch64')
+depends=('ghc-libs' 'haskell-errors' 'haskell-transformers-compat' 'haskell-transformers-base' 'haskell-juicypixels')
+makedepends=('ghc' 'haskell-errors' 'haskell-transformers-compat' 'haskell-transformers-base' 'haskell-juicypixels')
+source=(${pkgname}-${pkgver}.tar.gz::"https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz"
+ cabal.patch)
+sha256sums=('60b706f55f6cbfc8ef73eecf089a1d59ff939ac8a2c8f208af8f96211a067968'
+ '1a791e369c47f6f438c9db40151ab65a69e22af801c07f8645f82b86f0b6642b')
+
+prepare() {
+ cd ${_hkgname}-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}/cabal.patch"
+}
+
+build() {
+ cd ${_hkgname}-${pkgver}
+ runghc Setup.hs configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runghc Setup.hs build
+ runghc Setup.hs register --gen-script
+ runghc Setup.hs unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ runghc Setup.hs copy --destdir="${pkgdir}"
+ mkdir -p ${pkgdir}/usr/share/licenses/haskell-clay
+ mv "${pkgdir}/usr/share/doc/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/haskell-clay"
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+}
diff --git a/cabal.patch b/cabal.patch
new file mode 100644
index 000000000000..006a56e09fec
--- /dev/null
+++ b/cabal.patch
@@ -0,0 +1,13 @@
+diff --git a/latex-formulae-image.cabal b/latex-formulae-image.cabal
+index 22837c7..5204a98 100644
+--- a/latex-formulae-image.cabal
++++ b/latex-formulae-image.cabal
+@@ -38,7 +38,7 @@ library
+ build-depends: base >= 4.7 && < 4.8
+ , transformers-compat >= 0.4 && < 0.5
+ else
+- build-depends: base >= 4.8 && < 4.12
++ build-depends: base >= 4.8 && < 5
+ build-depends: JuicyPixels >= 3.2 && < 3.4
+ , errors >= 2.0 && < 2.4
+ , temporary >= 1.2 && < 1.4