summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPoscat2019-12-30 07:18:13 +0800
committerPoscat2019-12-30 07:18:13 +0800
commit86c82cb98191e0f4afaf39af7f27f5499f6127a9 (patch)
tree18e6bba9e8f0b62be92a848b64d1dc44385524a7
parent708d28677e0e5beb88d8299a0346379d100b372f (diff)
downloadaur-86c82cb98191e0f4afaf39af7f27f5499f6127a9.tar.gz
Patch source to make it build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--cabal.patch22
3 files changed, 34 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6414544946b4..7f06ad3339d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = haskell-latex-formulae-pandoc
pkgdesc = Render LaTeX formulae in pandoc documents to images with an actual LaTeX installation
pkgver = 0.2.0.6
- pkgrel = 2
+ pkgrel = 3
url = https://hackage.haskell.org/package/latex-formulae-pandoc
arch = x86_64
arch = i686
@@ -14,7 +14,9 @@ pkgbase = haskell-latex-formulae-pandoc
depends = haskell-pandoc-types
depends = haskell-latex-formulae-image
source = haskell-latex-formulae-pandoc-0.2.0.6.tar.gz::https://hackage.haskell.org/packages/archive/latex-formulae-pandoc/0.2.0.6/latex-formulae-pandoc-0.2.0.6.tar.gz
+ source = cabal.patch
sha256sums = 2efc0b9238e237eeacdf3c24f80b7a7546175d4edcb5e86a6f6ffad4769d0c88
+ sha256sums = dd8498cdc786abe005900574f1a05e0932fc74b6f6f25a10756e51a19fca6577
pkgname = haskell-latex-formulae-pandoc
diff --git a/PKGBUILD b/PKGBUILD
index 9dcc03f85aee..2393d4a749f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=haskell-latex-formulae-pandoc
_hkgname=latex-formulae-pandoc
pkgver=0.2.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="Render LaTeX formulae in pandoc documents to images with an actual LaTeX installation"
url="https://hackage.haskell.org/package/latex-formulae-pandoc"
license=('BSD')
@@ -13,8 +13,14 @@ depends=('ghc-libs'
'haskell-latex-formulae-image')
makedepends=('ghc')
source=(${pkgname}-${pkgver}.tar.gz::"https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz"
- )
-sha256sums=('2efc0b9238e237eeacdf3c24f80b7a7546175d4edcb5e86a6f6ffad4769d0c88')
+ cabal.patch)
+sha256sums=('2efc0b9238e237eeacdf3c24f80b7a7546175d4edcb5e86a6f6ffad4769d0c88'
+ 'dd8498cdc786abe005900574f1a05e0932fc74b6f6f25a10756e51a19fca6577')
+
+prepare() {
+ cd ${_hkgname}-${pkgver}
+ patch --forward --strip=1 --input="${srcdir}/cabal.patch"
+}
build() {
cd ${_hkgname}-${pkgver}
diff --git a/cabal.patch b/cabal.patch
new file mode 100644
index 000000000000..316167c64419
--- /dev/null
+++ b/cabal.patch
@@ -0,0 +1,22 @@
+diff --git a/latex-formulae-pandoc.cabal b/latex-formulae-pandoc.cabal
+index 743c06e..b2e6cdb 100644
+--- a/latex-formulae-pandoc.cabal
++++ b/latex-formulae-pandoc.cabal
+@@ -22,7 +22,7 @@ source-repository head
+ library
+ exposed-modules: Image.LaTeX.Render.Pandoc
+ build-depends: base >=4.7 && <5
+- , pandoc-types >= 1.12 && < 1.18
++ , pandoc-types >= 1.12
+ , latex-formulae-image >= 0.1 && < 0.2
+ , JuicyPixels >= 3.2 && < 3.4
+ , directory >= 1.2 && < 1.4
+@@ -38,7 +38,7 @@ executable latex-formulae-filter
+ main-is: Main.hs
+ ghc-options: -Wall
+ build-depends: base >=4.7 && <5, latex-formulae-pandoc
+- , pandoc-types >= 1.12 && < 1.18
++ , pandoc-types >= 1.12
+ , latex-formulae-image >= 0.1 && < 0.2
+ default-language: Haskell2010
+