summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeif Warner2015-07-08 23:36:40 -0700
committerLeif Warner2015-07-08 23:36:40 -0700
commit9966c7be8a343d11e8fef2d9bfae167cf26abfa8 (patch)
treee19e6b4322e0585d2876d8bcc6a638bec727d630
downloadaur-9966c7be8a343d11e8fef2d9bfae167cf26abfa8.tar.gz
Initial import 0.9.0.2
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD47
-rw-r--r--haskell-libmpd.install18
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..167132e2d8d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = haskell-libmpd
+ pkgdesc = An MPD client library.
+ pkgver = 0.9.0.2
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/libmpd
+ install = haskell-libmpd.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = ghc
+ depends = haskell-attoparsec<1
+ depends = haskell-bytestring<1
+ depends = haskell-containers
+ depends = haskell-data-default>=0.4
+ depends = haskell-filepath
+ depends = haskell-mtl<3
+ depends = haskell-network<3
+ depends = haskell-text>=0.11
+ depends = haskell-time<2
+ depends = haskell-utf8-string
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/libmpd/0.9.0.2/libmpd-0.9.0.2.tar.gz
+ md5sums = f02b903117e8284b30826b07ee8e0b52
+
+pkgname = haskell-libmpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c68eadf6f1e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Colin Woodbury <colingw@gmail.com>
+# Maintainer: Leif Warner <abimelech@gmail.com>
+# Contributor: Cedric Girard <girard.cedric@gmail.com>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+_hkgname=libmpd
+pkgname=haskell-libmpd
+pkgver=0.9.0.2
+pkgrel=1
+pkgdesc="An MPD client library."
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('LGPL')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc'
+ 'haskell-attoparsec<1'
+ 'haskell-bytestring<1'
+ 'haskell-containers'
+ 'haskell-data-default>=0.4'
+ 'haskell-filepath'
+ 'haskell-mtl<3'
+ 'haskell-network<3'
+ 'haskell-text>=0.11'
+ 'haskell-time<2'
+ 'haskell-utf8-string'
+)
+options=('staticlibs')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+md5sums=('f02b903117e8284b30826b07ee8e0b52')
+install=${pkgname}.install
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+}
diff --git a/haskell-libmpd.install b/haskell-libmpd.install
new file mode 100644
index 000000000000..84876683ae50
--- /dev/null
+++ b/haskell-libmpd.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-libmpd
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}