summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré van Delden2015-06-28 18:35:05 +0200
committerAndré van Delden2015-06-28 18:35:05 +0200
commit60168d8efb1d09a7e0f71562f82d3bcfdf8b79c1 (patch)
tree6f241f1cc6305308187cd20f5041302d03fe8f87
downloadaur-60168d8efb1d09a7e0f71562f82d3bcfdf8b79c1.tar.gz
Initial import
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD36
-rw-r--r--haskell-linear.install18
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9258ca80433f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = haskell-linear
+ pkgdesc = Linear Algebra
+ pkgver = 1.17.1
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/linear
+ install = haskell-linear.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-adjunctions<5
+ depends = haskell-binary<0.8
+ depends = haskell-bytes<1
+ depends = haskell-cereal<0.5
+ depends = haskell-containers=0.4.0.0
+ depends = haskell-deepseq=1.1.0.2
+ depends = haskell-distributive<1
+ depends = haskell-hashable<1.3
+ depends = haskell-lens<5
+ depends = haskell-reflection<2
+ depends = haskell-semigroupoids<5
+ depends = haskell-semigroups<1
+ depends = haskell-tagged<1
+ depends = haskell-template-haskell
+ depends = haskell-transformers=0.2.2.0
+ depends = haskell-transformers-compat<1
+ depends = haskell-unordered-containers<0.3
+ depends = haskell-vector<0.11
+ depends = haskell-void<1
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/linear/1.17.1/linear-1.17.1.tar.gz
+ sha512sums = b60dd3d259a7cdbdb912c790a1d6af0ed287feb8bce99dfdd12810667ba47abb80dc4d0d4d0db8a57a334812fc814521016a23734421178b7e1d5dddf090b4b3
+
+pkgname = haskell-linear
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7c1246d0b1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: André van Delden <andre.van.delden@uni-bremen.de>
+
+_hkgname=linear
+pkgname=haskell-linear
+pkgver=1.17.1
+pkgrel=1
+pkgdesc="Linear Algebra"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-adjunctions<5' 'haskell-binary<0.8' 'haskell-bytes<1' 'haskell-cereal<0.5' 'haskell-containers=0.4.0.0' 'haskell-deepseq=1.1.0.2' 'haskell-distributive<1' 'haskell-hashable<1.3' 'haskell-lens<5' 'haskell-reflection<2' 'haskell-semigroupoids<5' 'haskell-semigroups<1' 'haskell-tagged<1' 'haskell-template-haskell' 'haskell-transformers=0.2.2.0' 'haskell-transformers-compat<1' 'haskell-unordered-containers<0.3' 'haskell-vector<0.11' 'haskell-void<1')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+sha512sums=('b60dd3d259a7cdbdb912c790a1d6af0ed287feb8bce99dfdd12810667ba47abb80dc4d0d4d0db8a57a334812fc814521016a23734421178b7e1d5dddf090b4b3')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/haskell-linear.install b/haskell-linear.install
new file mode 100644
index 000000000000..03c2afbdb996
--- /dev/null
+++ b/haskell-linear.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-linear
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}