summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-07-31 13:53:40 -0400
committerSolomon Choina2019-07-31 13:53:40 -0400
commit14f6005136b6dea6a0bec7f54189e61f11440082 (patch)
tree28d22857cfcbaf5aefefe6ba930fe14602a8ffa6
downloadaur-14f6005136b6dea6a0bec7f54189e61f11440082.tar.gz
initial import from parent git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1b969a2e3d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = haskell-missingh
+ pkgdesc = Large utility library
+ pkgver = 1.4.2.0
+ pkgrel = 1
+ url = http://software.complete.org/missingh
+ arch = x86_64
+ license = BSD
+ makedepends = ghc
+ makedepends = haskell-hunit
+ depends = ghc-libs
+ depends = haskell-hslogger
+ depends = haskell-network
+ depends = haskell-old-locale
+ depends = haskell-old-time
+ depends = haskell-random
+ depends = haskell-regex-compat
+ source = https://hackage.haskell.org/packages/archive/MissingH/1.4.2.0/MissingH-1.4.2.0.tar.gz
+ sha512sums = 6e97ac1c7a126c17a9497bf5afcfab11a2bbf56358ef013f1e7ac5d4095b531976157e9bba1b3abab7a45c98e4d3525e919c926506842e56ef721edcbd944b3c
+
+pkgname = haskell-missingh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fa044fa6c60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+_hkgname=MissingH
+pkgname=haskell-missingh
+pkgver=1.4.2.0
+pkgrel=1
+pkgdesc="Large utility library"
+url="http://software.complete.org/missingh"
+license=("BSD")
+arch=('x86_64')
+depends=('ghc-libs' "haskell-hslogger" "haskell-network"
+ "haskell-old-locale" "haskell-old-time" "haskell-random"
+ "haskell-regex-compat")
+makedepends=('ghc' 'haskell-hunit')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha512sums=('6e97ac1c7a126c17a9497bf5afcfab11a2bbf56358ef013f1e7ac5d4095b531976157e9bba1b3abab7a45c98e4d3525e919c926506842e56ef721edcbd944b3c')
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}