summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Lenz2019-09-25 00:45:54 +0200
committerNicolas Lenz2019-09-25 00:45:54 +0200
commit19bc1d9a55fd6f09574b803da653cbc7a02f6029 (patch)
tree46f7c637290460d97a88e09eb327e928f578caa4
parent1ec82bb78620844b1bbc5c0e3c92d609a8b9c9cc (diff)
downloadaur-19bc1d9a55fd6f09574b803da653cbc7a02f6029.tar.gz
Fix wrong paths because of gitea -> gitlab
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f2786d8bd35..14eac28b9205 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
pkgname=haskell-mock
pkgver=3.6.0
-pkgrel=3
+pkgrel=4
pkgdesc="Great Haskell tool to transform text"
url="https://git.eisfunke.com/software/mock"
license=("custom:WTFPL")
arch=("x86_64")
depends=("haskell-array" "haskell-base" "haskell-binary" "haskell-bytestring" "haskell-deepseq" "haskell-ghc-prim" "haskell-hashable" "haskell-integer-gmp" "haskell-random" "haskell-text" "haskell-time")
makedepends=("ghc" "haskell-hpack")
-source=("${pkgname}-${pkgver}.tar.gz::https://git.eisfunke.com/software/mock/-/archive/v${pkgver}.tar.gz")
-sha256sums=("5d202393aeae7b33775b498fb10235c33c28f3b66d00126a4b145035a84bf395")
+source=("${pkgname}-${pkgver}.tar.gz::https://git.eisfunke.com/software/mock/-/archive/v${pkgver}/mock-v${pkgver}.tar.gz")
+sha256sums=("5c99d6b9503da9d470d7a681f1ddd9e46e1b0e90ba4e5d37adc4e387ef0a7fc1")
build() {
- cd "${srcdir}/mock"
+ cd "${srcdir}/mock-v${pkgver}"
hpack
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
@@ -27,7 +27,7 @@ build() {
}
package() {
- cd "${srcdir}/mock"
+ cd "${srcdir}/mock-v${pkgver}"
install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"