summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Lenz2019-06-10 17:56:42 +0200
committerNicolas Lenz2019-06-10 17:56:42 +0200
commitf1b16bcde4c5c8805383eef238110b9469f46478 (patch)
tree924e56aaf25e70a64565c1a76e58c608d71c1b34
parent4c92ef0b6c46640882a52afae977f8bbad59ff53 (diff)
downloadaur-f1b16bcde4c5c8805383eef238110b9469f46478.tar.gz
Fix: Generate cabal file with hpack
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da0ecc81fd6d..20df6315f625 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = haskell-mock
pkgdesc = Great Haskell tool to transform text
pkgver = 3.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://git.eisfunke.com/software/mock
arch = x86_64
license = custom:WTFPL
@@ -17,6 +17,7 @@ pkgbase = haskell-mock
depends = haskell-random
depends = haskell-text
depends = haskell-time
+ depends = haskell-hpack
source = haskell-mock-3.5.0.tar.gz::https://git.eisfunke.com/software/mock/archive/v3.5.0.tar.gz
sha256sums = 995418b41413387a32794da6ca03a48901aa417c4c47e8c56b919c12b06e168c
diff --git a/PKGBUILD b/PKGBUILD
index a767e8b9da17..b8bfd90730a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=haskell-mock
pkgver=3.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Great Haskell tool to transform text"
url="https://git.eisfunke.com/software/mock"
license=("custom:WTFPL")
arch=("x86_64")
-depends=("haskell-array" "haskell-base" "haskell-binary" "haskell-bytestring" "haskell-deepseq" "haskell-ghc-prim" "haskell-hashable" "haskell-integer-gmp" "haskell-random" "haskell-text" "haskell-time")
+depends=("haskell-array" "haskell-base" "haskell-binary" "haskell-bytestring" "haskell-deepseq" "haskell-ghc-prim" "haskell-hashable" "haskell-integer-gmp" "haskell-random" "haskell-text" "haskell-time" "haskell-hpack")
makedepends=("ghc")
source=("${pkgname}-${pkgver}.tar.gz::https://git.eisfunke.com/software/mock/archive/v${pkgver}.tar.gz")
sha256sums=("995418b41413387a32794da6ca03a48901aa417c4c47e8c56b919c12b06e168c")
@@ -16,6 +16,7 @@ sha256sums=("995418b41413387a32794da6ca03a48901aa417c4c47e8c56b919c12b06e168c")
build() {
cd "${srcdir}/mock"
+ hpack
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
--prefix=/usr --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build