summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaron Kent-Dobias2019-02-06 09:36:44 -0500
committerJaron Kent-Dobias2019-02-06 09:36:44 -0500
commitb0ab1075b5f21f41fbc117436ebe0af664e74e24 (patch)
treea45fa89b29ae67e3f2b9e04c67181789e884fbb6
downloadaur-b0ab1075b5f21f41fbc117436ebe0af664e74e24.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
-rw-r--r--haskell-monoid-extras.patch25
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cec4eeaedab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = haskell-monoid-extras
+ pkgdesc = Various extra monoid-related definitions and utilities.
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/monoid-extras
+ arch = x86_64
+ license = BSD-3
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-groups
+ depends = haskell-semigroupoids
+ source = https://hackage.haskell.org/package/monoid-extras-0.5/monoid-extras-0.5.tar.gz
+ source = haskell-monoid-extras.patch
+ sha512sums = 3e30d3dbddb58ad8093a7ad8d42a662303668006f15bec648ca2d78fcf1637696e889a26109d6652fe27de0e732f86be6b0a29d6df262e305b63915312032ba4
+ sha512sums = 6ea2664836f0f669dbd06d3856d61316adf8e4f83d289574a7ffb3150c022a6e9c098c94f120ce6af5c7e1ed491f622fca114acd8a5dfdf5be089a64a8860e62
+
+pkgname = haskell-monoid-extras
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71261e6fd2e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+
+_hkgname=monoid-extras
+pkgname=haskell-monoid-extras
+pkgver=0.5
+pkgrel=1
+pkgdesc='Various extra monoid-related definitions and utilities.'
+url='https://hackage.haskell.org/package/monoid-extras'
+license=('BSD-3')
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-groups' 'haskell-semigroupoids')
+makedepends=('ghc')
+source=(https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz
+ haskell-monoid-extras.patch)
+sha512sums=('3e30d3dbddb58ad8093a7ad8d42a662303668006f15bec648ca2d78fcf1637696e889a26109d6652fe27de0e732f86be6b0a29d6df262e305b63915312032ba4'
+ '6ea2664836f0f669dbd06d3856d61316adf8e4f83d289574a7ffb3150c022a6e9c098c94f120ce6af5c7e1ed491f622fca114acd8a5dfdf5be089a64a8860e62')
+
+prepare() {
+ cd ${_hkgname}-${pkgver}
+ patch -Np1 -i "${srcdir}/haskell-monoid-extras.patch"
+}
+
+build() {
+ cd ${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -dm 755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 CHANGES -t "${pkgdir}/usr/share/doc/${pkgname}"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/haskell-monoid-extras.patch b/haskell-monoid-extras.patch
new file mode 100644
index 000000000000..1512c613c5d2
--- /dev/null
+++ b/haskell-monoid-extras.patch
@@ -0,0 +1,25 @@
+diff -ura monoid-extras-0.5/monoid-extras.cabal monoid-extras-0.5.new/monoid-extras.cabal
+--- monoid-extras-0.5/monoid-extras.cabal 2018-05-14 18:31:06.000000000 -0400
++++ monoid-extras-0.5.new/monoid-extras.cabal 2019-02-06 09:34:08.496864388 -0500
+@@ -35,10 +35,9 @@
+ Data.Monoid.Split,
+ Data.Monoid.WithSemigroup
+
+- build-depends: base >= 4.3 && < 4.12,
++ build-depends: base >= 4.3,
+ groups < 0.5,
+- semigroups >= 0.8 && < 0.19,
+- semigroupoids >= 4.0 && < 5.3
++ semigroupoids >= 4.0
+
+ hs-source-dirs: src
+
+@@ -52,7 +51,6 @@
+ hs-source-dirs: benchmarks
+ main-is: SemiDirectProduct.hs
+ type: exitcode-stdio-1.0
+- build-depends: base >= 4.3 && < 4.12
+- , semigroups
++ build-depends: base >= 4.3
+ , criterion
+ , monoid-extras