summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Dressel2023-05-20 18:46:45 +0200
committerMichael Dressel2023-05-20 18:46:45 +0200
commit4fdb49b46e0a5996274decd077722f8f3281cf59 (patch)
tree4a459240a61884c8dc840d8f8d31a5418406acfd
downloadaur-4fdb49b46e0a5996274decd077722f8f3281cf59.tar.gz
Initial commit for haskell-multipletcombiner
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..322cf663915a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haskell-multipletcombiner
+ pkgdesc = A Haskell implementation for combining SU(n) multiplets
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/mdrslmr/MultipletCombiner
+ arch = x86_64
+ license = BSD
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-call-stack
+ optdepends = haskell-hunit: for unit tests
+ source = https://hackage.haskell.org/packages/archive/MultipletCombiner/0.0.3/MultipletCombiner-0.0.3.tar.gz
+ sha512sums = ca22b4efcaff4001b1b41f406fac0077b60ef6b56e97c969deb5bc806471a88f501ead757542573412b55f74c593c271923131a23b17b0ab7c969303dba9147e
+
+pkgname = haskell-multipletcombiner
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa1be06a379a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Michael Dressel <mdrslmr@kloenplatz.de>
+_hkgname=MultipletCombiner
+pkgname=haskell-multipletcombiner
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="A Haskell implementation for combining SU(n) multiplets"
+arch=('x86_64')
+url="https://github.com/mdrslmr/MultipletCombiner"
+license=('BSD')
+#groups=()
+depends=('ghc-libs' 'haskell-call-stack')
+makedepends=('ghc')
+optdepends=('haskell-hunit: for unit tests')
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+#options=()
+#install=
+#changelog=
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+#noextract=()
+sha512sums=(ca22b4efcaff4001b1b41f406fac0077b60ef6b56e97c969deb5bc806471a88f501ead757542573412b55f74c593c271923131a23b17b0ab7c969303dba9147e)
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
+ -fbase4
+ runhaskell Setup build $MAKEFLAGS
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}