summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author71e6fd522020-02-29 13:14:21 +0800
committer71e6fd522020-02-29 13:14:21 +0800
commitf8ad722dc189e52648a33a2eb2808563040e82b1 (patch)
tree75929b09666a5c43770b95773668d63d9fecbbce
downloadaur-f8ad722dc189e52648a33a2eb2808563040e82b1.tar.gz
0.8.0.2
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD42
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7242b1928c16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = haskell-multistate
+ pkgdesc = like mtl's ReaderT / WriterT / StateT, but more than one contained value/type.
+ pkgver = 0.8.0.2
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/multistate
+ arch = x86_64
+ license = BSD3
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-hspec
+ depends = haskell-monad-control
+ depends = haskell-mtl
+ depends = haskell-tagged
+ depends = haskell-transformers
+ depends = haskell-transformers-base
+ source = https://hackage.haskell.org/packages/archive/multistate/0.8.0.2/multistate-0.8.0.2.tar.gz
+ sha512sums = 5e8e41a5a0de3973e097b388dca95f2ca6e0b1155d2b34021a448c68e52c29e0c4b49c5211c1ced2c1c679b06753daccca2d69740b0efae277e5a09196f4ec6c
+
+pkgname = haskell-multistate
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e8409730516
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!.*
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83752366cf06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: 71e6fd52 <71e6fd52 at gmail dot com>
+
+_hkgname=multistate
+pkgname=haskell-multistate
+pkgver=0.8.0.2
+pkgrel=1
+pkgdesc="like mtl's ReaderT / WriterT / StateT, but more than one contained value/type."
+url='https://hackage.haskell.org/package/multistate'
+license=('BSD')
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-hspec' 'haskell-monad-control' 'haskell-mtl' 'haskell-tagged' 'haskell-transformers' 'haskell-transformers-base')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha512sums=('5e8e41a5a0de3973e097b388dca95f2ca6e0b1155d2b34021a448c68e52c29e0c4b49c5211c1ced2c1c679b06753daccca2d69740b0efae277e5a09196f4ec6c')
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+check() {
+ cd $_hkgname-$pkgver
+ runhaskell Setup test
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}