summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:31:07 +0200
committerDaniel Nagy2015-06-08 20:31:07 +0200
commit7f10fe9c0eeae8b89d5566319f731cbf18e9a8d0 (patch)
tree8f4021e06f294027991d9dbb09f5ff80cdf5b5c2
downloadaur-7f10fe9c0eeae8b89d5566319f731cbf18e9a8d0.tar.gz
import to aur4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--haskell-openglraw.install18
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5eda45cda85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = haskell-openglraw
+ pkgdesc = A raw binding for the OpenGL graphics system
+ pkgver = 1.5.0.1
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/OpenGLRaw
+ install = haskell-openglraw.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = libgl
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/OpenGLRaw/1.5.0.1/OpenGLRaw-1.5.0.1.tar.gz
+ md5sums = cfb842754fe17a2bdc16f0e155a6aced
+
+pkgname = haskell-openglraw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb0c98ab9afc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Austin Robinson <austin.rbsn@gmail.com>
+
+_hkgname=OpenGLRaw
+pkgname=haskell-openglraw
+pkgver=1.5.0.1
+pkgrel=1
+pkgdesc="A raw binding for the OpenGL graphics system"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'libgl')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+md5sums=('cfb842754fe17a2bdc16f0e155a6aced')
+
+build() {
+ cd "${srcdir}"/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd "${srcdir}"/${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}"/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh "${pkgdir}"/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 "${pkgdir}"/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ rm -f "${pkgdir}"/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/haskell-openglraw.install b/haskell-openglraw.install
new file mode 100644
index 000000000000..1ee90cbbee23
--- /dev/null
+++ b/haskell-openglraw.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-openglraw
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}