summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaron Kent-Dobias2019-02-05 18:31:59 -0500
committerJaron Kent-Dobias2019-02-05 18:31:59 -0500
commit0c10b215941970d9001fca938c94fe48804e729b (patch)
tree19635be6d6f3af5df8c96b1cde4c8d6d8721fced
downloadaur-0c10b215941970d9001fca938c94fe48804e729b.tar.gz
initialized repository for haskell-operational
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..890ccc464abd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haskell-operational
+ pkgdesc = A wrapper to gnuplot which lets you create 2D and 3D plots.
+ pkgver = 0.2.3.5
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/operational
+ arch = x86_64
+ license = BSD-3
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-random
+ source = https://hackage.haskell.org/package/operational-0.2.3.5/operational-0.2.3.5.tar.gz
+ sha512sums = 80ddcadc3aaa1b37514d31441f81b7d5e89263921f26ba2d877327a8eeb95da99f858ea54f2e72b6413f08a8e85b3fa54bac9d3327e5a63945ad90a25be51ed4
+
+pkgname = haskell-operational
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2588bd198f57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+
+_hkgname=operational
+pkgname=haskell-operational
+pkgver=0.2.3.5
+pkgrel=1
+pkgdesc='A wrapper to gnuplot which lets you create 2D and 3D plots.'
+url='https://hackage.haskell.org/package/operational'
+license=('BSD-3')
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-random')
+makedepends=('ghc')
+source=(https://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+sha512sums=('80ddcadc3aaa1b37514d31441f81b7d5e89263921f26ba2d877327a8eeb95da99f858ea54f2e72b6413f08a8e85b3fa54bac9d3327e5a63945ad90a25be51ed4')
+
+build() {
+ cd ${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -dm 755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm 644 CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+}
+
+# vim: ts=2 sw=2 et: