summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshwin Vishnu2020-06-09 20:43:24 +0200
committerAshwin Vishnu2020-06-09 20:43:24 +0200
commit2c0e5e87f7e857a0a3230cc47ffc55831873e451 (patch)
treebbacbda2eeb453c75c20f3195261ce836fc275f0
parent0ce47512ad3e3cb010be805565664bf5cfbe03f6 (diff)
downloadaur-2c0e5e87f7e857a0a3230cc47ffc55831873e451.tar.gz
Rename and rewrite package
New name: haskell-pandoc-citeproc-bin Also packages locales, license etc.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD46
2 files changed, 40 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24bbb950c7a9..c9506620ecee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
-pkgbase = pandoc-citeproc-bin
- pkgdesc = Pandoc Cite Processor - executable only, without 750MB Haskell depends/makedepends
- pkgver = 2.9.2.1
+pkgbase = haskell-pandoc-citeproc-bin
+ pkgdesc = Supports using pandoc with citeproc - executable only
+ pkgver = 0.17
pkgrel = 1
url = https://hackage.haskell.org/package/pandoc-citeproc
arch = x86_64
- license = custom:BSD3
+ license = BSD
depends = pandoc
provides = pandoc-citeproc
conflicts = pandoc-citeproc
+ replaces = pandoc-citeproc-bin
replaces = pandoc-citeproc-static
replaces = pandoc-citeproc-lite
- source = https://github.com/jgm/pandoc/releases/download/2.9.2.1/pandoc-2.9.2.1-linux-amd64.tar.gz
+ source = pandoc-2.9.2.1.tar.gz::https://github.com/jgm/pandoc/releases/download/2.9.2.1/pandoc-2.9.2.1-linux-amd64.tar.gz
+ source = pandoc-citeproc-0.17.tar.gz::https://github.com/jgm/pandoc-citeproc/archive/0.17.tar.gz
sha256sums = 5b61a981bd2b7d48c1b4ba5788f1386631f97e2b46d0d1f1a08787091b4b0cf8
+ sha256sums = 7d5f736afeb7f4efa626e18cce0b2cbf8f52e6b367295a959bcdb7c5c37f1126
-pkgname = pandoc-citeproc-bin
+pkgname = haskell-pandoc-citeproc-bin
diff --git a/PKGBUILD b/PKGBUILD
index 71c5e975b6f2..dff2f3b2f320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,42 @@
-pkgname=pandoc-citeproc-bin
-pkgver=2.9.2.1
+pkgname=haskell-pandoc-citeproc-bin
+_pkgname=pandoc-citeproc
+pkgver=0.17
+_pandoc_ver=2.9.2.1
pkgrel=1
-pkgdesc="Pandoc Cite Processor - executable only, without 750MB Haskell depends/makedepends"
-url="https://hackage.haskell.org/package/pandoc-citeproc"
-license=("custom:BSD3")
-arch=('x86_64')
+pkgdesc="Supports using pandoc with citeproc - executable only"
+url="https://hackage.haskell.org/package/${_pkgname}"
+license=("BSD")
+arch=("x86_64")
conflicts=("pandoc-citeproc")
provides=("pandoc-citeproc")
-replaces=('pandoc-citeproc-static' 'pandoc-citeproc-lite')
-depends=('pandoc')
+replaces=("pandoc-citeproc-bin" "pandoc-citeproc-static" "pandoc-citeproc-lite")
+depends=("pandoc")
source=(
- "https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-amd64.tar.gz"
+ "pandoc-${_pandoc_ver}.tar.gz::https://github.com/jgm/pandoc/releases/download/${_pandoc_ver}/pandoc-${_pandoc_ver}-linux-amd64.tar.gz"
+ "${_pkgname}-${pkgver}.tar.gz::https://github.com/jgm/${_pkgname}/archive/${pkgver}.tar.gz"
)
-sha256sums=('5b61a981bd2b7d48c1b4ba5788f1386631f97e2b46d0d1f1a08787091b4b0cf8')
+sha256sums=('5b61a981bd2b7d48c1b4ba5788f1386631f97e2b46d0d1f1a08787091b4b0cf8'
+ '7d5f736afeb7f4efa626e18cce0b2cbf8f52e6b367295a959bcdb7c5c37f1126')
package() {
+ cd "${srcdir}/pandoc-${_pandoc_ver}"
+ mkdir -p "${pkgdir}/usr"
+
# the original pandoc executable is provided by a different package.
- rm "${srcdir}/pandoc-${pkgver}/bin/pandoc"
- rm "${srcdir}/pandoc-${pkgver}/share/man/man1/pandoc.1.gz"
+ rm bin/pandoc
+ rm share/man/man1/pandoc.1.gz
+
+ cp -r bin share "${pkgdir}/usr"
+
+ # the source tarball provides the right license, changelog, readme and
+ # locales
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}"
- mkdir "${pkgdir}/usr"
- cp -r "${srcdir}/pandoc-${pkgver}/bin" "${pkgdir}/usr"
- cp -r "${srcdir}/pandoc-${pkgver}/share" "${pkgdir}/usr"
+ mkdir -p "${pkgdir}/usr/share/${_pkgname}"
+ install -Dm 644 changelog README.md "${pkgdir}/usr/share/${_pkgname}/"
+ cp -r locales "${pkgdir}/usr/share/${_pkgname}/"
}