summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2017-10-07 16:12:49 +0300
committerDoron Behar2017-10-07 16:33:01 +0300
commit3b00c77b380ef93b4c6bcccea74f459d1eea02ef (patch)
tree4d9a42ae7adfc6e105f630800f855367c1e64686
downloadaur-3b00c77b380ef93b4c6bcccea74f459d1eea02ef.tar.gz
Copy `PKGBUILD` and `.SRCINFO` from `pandoc-bin`.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD45
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a4fcaf8ab80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Oct 3 08:45:25 UTC 2017
+pkgbase = pandoc-bin
+ pkgdesc = Pandoc - executable only, without 750MB Haskell depends/makedepends
+ pkgver = 1.19.2.1
+ pkgrel = 1
+ url = http://pandoc.org
+ arch = x86_64
+ license = GPL
+ depends = cmark
+ provides = pandoc
+ conflicts = pandoc
+ replaces = pandoc-static
+ replaces = pandoc-lite
+ source = https://github.com/jgm/pandoc/releases/download/1.19.2.1/pandoc-1.19.2.1-1-amd64.deb
+ source = https://hackage.haskell.org/package/pandoc-1.19.2.1/pandoc-1.19.2.1.tar.gz
+ sha256sums = db828cbab2a6d0d33f3754c4061a844ae2d1f0a01cbb12c512ef109117595dd2
+ sha256sums = 08692f3d77bf95bb9ba3407f7af26de7c23134e7efcdafad0bdaf9050e2c7801
+
+pkgname = pandoc-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23a5716d83b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=pandoc-bin
+pkgver=1.19.2.1
+pkgrel=1
+pkgdesc="Pandoc - executable only, without 750MB Haskell depends/makedepends"
+url="http://pandoc.org"
+license=("GPL")
+arch=('x86_64')
+conflicts=("pandoc")
+provides=("pandoc")
+replaces=('pandoc-static' 'pandoc-lite')
+depends=('cmark')
+
+source=(
+ "https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-1-amd64.deb"
+
+ # Note that they use a git submodule for data/templates, so soure tarballs from github are incomplete.
+ # Fetching from hackage gets us a complete tarball without writing our own `git submodule` commands.
+ "https://hackage.haskell.org/package/pandoc-${pkgver}/pandoc-${pkgver}.tar.gz"
+)
+sha256sums=(
+ "db828cbab2a6d0d33f3754c4061a844ae2d1f0a01cbb12c512ef109117595dd2"
+ "08692f3d77bf95bb9ba3407f7af26de7c23134e7efcdafad0bdaf9050e2c7801"
+)
+
+package() {
+ cd "${srcdir}"
+
+ # To avoid having to download over a gigabyte of haskell makedepends (400-ish for ghc, plus 750 in libs), we
+ # just yoink the binary from static compiled binary distributed by pandoc:
+ tar -zxf data.tar.gz
+ cp -R usr "${pkgdir}/"
+
+ # Citeproc is provided by a different package, and depends on various other datafiles we don't handle here.
+ rm "${pkgdir}/usr/bin/pandoc-citeproc"
+ rm "${pkgdir}/usr/share/man/man1/pandoc-citeproc.1.gz"
+ rm -R "${pkgdir}/usr/share/doc/pandoc-citeproc"
+
+ # We're still missing all the datafiles and so on. We get those from the source tarball...
+ cd "pandoc-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/pandoc/"
+
+ cp -R data "${pkgdir}/usr/share/pandoc/"
+ cp COPYRIGHT "${pkgdir}/usr/share/pandoc/COPYRIGHT"
+ cp MANUAL.txt "${pkgdir}/usr/share/pandoc/MANUAL.txt"
+}