summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer2018-05-12 19:44:22 -0400
committerCody P Schafer2018-05-12 19:44:22 -0400
commit53130352ff609462a4a62ce55f3246b94ed4e992 (patch)
tree2ec29f204caccbc9e13887a4e3fa6476e1978562
parentdff2b908c259d099b33331c792102a755e091f8e (diff)
downloadaur-53130352ff609462a4a62ce55f3246b94ed4e992.tar.gz
update for new arch haskell stuff
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb6695573542..a6aa611a9ca6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,9 +22,9 @@ md5sums=('492b7ecc53d0ac3599845ab8ac553997')
build() {
cd "$srcdir/${_ipn}-${pkgver}"
- runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
- --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
runhaskell Setup register --gen-script