summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:31:34 +0200
committerDaniel Nagy2015-06-08 20:31:34 +0200
commit56db1fd7d902016cafab94921c1e46b14377e4d9 (patch)
treedd337b0fb4995a2de5b3d198b523fe45402d602d
downloadaur-56db1fd7d902016cafab94921c1e46b14377e4d9.tar.gz
import to aur4
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD36
-rw-r--r--haskell-semigroups.install18
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b473aaee939
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = haskell-semigroups
+ pkgdesc = Anything that associates
+ pkgver = 0.16.2.2
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/semigroups
+ install = haskell-semigroups.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-bytestring>=0.9
+ depends = haskell-deepseq
+ depends = haskell-ghc-prim
+ depends = haskell-containers>=0.3
+ depends = haskell-hashable>=1.1
+ depends = haskell-nats>0.1
+ depends = haskell-text>=0.10
+ depends = haskell-unordered-containers>=0.2
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/semigroups/0.16.2.2/semigroups-0.16.2.2.tar.gz
+ md5sums = 728f760bca161acdccbe23dfb4fb43db
+
+pkgname = haskell-semigroups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaee43c9840b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+_hkgname=semigroups
+pkgname=haskell-semigroups
+pkgver=0.16.2.2
+pkgrel=1
+pkgdesc="Anything that associates"
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-bytestring>=0.9' 'haskell-deepseq' 'haskell-ghc-prim' 'haskell-containers>=0.3' 'haskell-hashable>=1.1' 'haskell-nats>0.1' 'haskell-text>=0.10' 'haskell-unordered-containers>=0.2')
+options=('strip' 'staticlibs' )
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+md5sums=('728f760bca161acdccbe23dfb4fb43db')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/haskell-semigroups.install b/haskell-semigroups.install
new file mode 100644
index 000000000000..8369ace055a7
--- /dev/null
+++ b/haskell-semigroups.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-semigroups
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}