summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-06-08 11:31:37 -0400
committerSolomon Choina2018-06-08 11:31:37 -0400
commit9fe0d91bf0eed7ea467708edf277616644a64cb5 (patch)
tree79284c08d47d339103d1b502a06ac5de221fa16e
parent56db1fd7d902016cafab94921c1e46b14377e4d9 (diff)
downloadaur-9fe0d91bf0eed7ea467708edf277616644a64cb5.tar.gz
removing .install
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD21
-rw-r--r--haskell-semigroups-0.18.4-2-x86_64-build.log27
-rw-r--r--haskell-semigroups-0.18.4-2-x86_64-package.log1
-rw-r--r--semigroups-0.18.4.tar.gzbin0 -> 19869 bytes
5 files changed, 49 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b473aaee939..c74e932aebb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = haskell-semigroups
pkgdesc = Anything that associates
- pkgver = 0.16.2.2
- pkgrel = 1
+ pkgver = 0.18.4
+ pkgrel = 2
url = http://hackage.haskell.org/package/semigroups
- install = haskell-semigroups.install
arch = i686
arch = x86_64
license = custom:BSD3
- depends = ghc
- depends = haskell-bytestring>=0.9
+ makedepends = ghc
+ depends = haskell-bytestring
depends = haskell-deepseq
depends = haskell-ghc-prim
- depends = haskell-containers>=0.3
- depends = haskell-hashable>=1.1
- depends = haskell-nats>0.1
- depends = haskell-text>=0.10
- depends = haskell-unordered-containers>=0.2
- options = strip
- options = staticlibs
- source = http://hackage.haskell.org/packages/archive/semigroups/0.16.2.2/semigroups-0.16.2.2.tar.gz
- md5sums = 728f760bca161acdccbe23dfb4fb43db
+ depends = haskell-containers
+ depends = haskell-hashable
+ depends = haskell-nats
+ depends = haskell-text
+ depends = haskell-unordered-containers
+ source = http://hackage.haskell.org/packages/archive/semigroups/0.18.4/semigroups-0.18.4.tar.gz
+ sha256sums = 589e3042329a6bcffb5c0e85834143586db22eb7a2aae094d492cd004f685d27
pkgname = haskell-semigroups
diff --git a/PKGBUILD b/PKGBUILD
index aaee43c9840b..57a576a6531a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-# Maintainer: Daniel Nagy <danielnagy at gmx de>
-
+# Maintainer: Solomon Choina <shlomochoina@gmail.com
_hkgname=semigroups
pkgname=haskell-semigroups
-pkgver=0.16.2.2
-pkgrel=1
+pkgver=0.18.4
+pkgrel=2
pkgdesc="Anything that associates"
url="http://hackage.haskell.org/package/${_hkgname}"
license=('custom:BSD3')
arch=('i686' 'x86_64')
-makedepends=()
-depends=('ghc' 'haskell-bytestring>=0.9' 'haskell-deepseq' 'haskell-ghc-prim' 'haskell-containers>=0.3' 'haskell-hashable>=1.1' 'haskell-nats>0.1' 'haskell-text>=0.10' 'haskell-unordered-containers>=0.2')
-options=('strip' 'staticlibs' )
+makedepends=(ghc)
+depends=('haskell-bytestring' 'haskell-deepseq' 'haskell-ghc-prim' 'haskell-containers' 'haskell-hashable' 'haskell-nats' 'haskell-text' 'haskell-unordered-containers')
source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
-install=${pkgname}.install
-md5sums=('728f760bca161acdccbe23dfb4fb43db')
+sha256sums=('589e3042329a6bcffb5c0e85834143586db22eb7a2aae094d492cd004f685d27')
build() {
cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
package() {
diff --git a/haskell-semigroups-0.18.4-2-x86_64-build.log b/haskell-semigroups-0.18.4-2-x86_64-build.log
new file mode 100644
index 000000000000..79b5b3701ff6
--- /dev/null
+++ b/haskell-semigroups-0.18.4-2-x86_64-build.log
@@ -0,0 +1,27 @@
+Configuring semigroups-0.18.4...
+Preprocessing library for semigroups-0.18.4..
+Building library for semigroups-0.18.4..
+[1 of 1] Compiling Data.Semigroup.Generic ( src/Data/Semigroup/Generic.hs, dist/build/Data/Semigroup/Generic.dyn_o )
+
+src/Data/Semigroup/Generic.hs:30:1: warning: [-Wunused-imports]
+ The import of ‘Data.Semigroup’ is redundant
+ except perhaps to import instances from ‘Data.Semigroup’
+ To import instances alone, use: import Data.Semigroup()
+ |
+30 | import Data.Semigroup
+ | ^^^^^^^^^^^^^^^^^^^^^
+ignoring (possibly broken) abi-depends field for packages
+Preprocessing library for semigroups-0.18.4..
+Running Haddock on library for semigroups-0.18.4..
+Warning: The documentation for the following packages are not installed. No
+links will be generated to these packages: base-4.11.1.0, ghc-prim-0.5.2.0,
+integer-gmp-1.0.2.0
+Haddock coverage:
+ 60% ( 3 / 5) in 'Data.Semigroup.Generic'
+ Missing documentation for:
+ GSemigroup (src/Data/Semigroup/Generic.hs:44)
+ GMonoid (src/Data/Semigroup/Generic.hs:74)
+Warning: Data.Semigroup.Generic: could not find link destinations for:
+ gmappend' V1 * U1 K1 Semigroup :*: M1 Generic Rep <> gmempty' Monoid mempty
+Documentation created: dist/doc/html/semigroups/index.html
+Unregistering semigroups-0.18.4...
diff --git a/haskell-semigroups-0.18.4-2-x86_64-package.log b/haskell-semigroups-0.18.4-2-x86_64-package.log
new file mode 100644
index 000000000000..4b8e07c91ca4
--- /dev/null
+++ b/haskell-semigroups-0.18.4-2-x86_64-package.log
@@ -0,0 +1 @@
+Installing library in /build/haskell-semigroups/pkg/haskell-semigroups/usr/lib/ghc-8.4.3/site-local/semigroups-0.18.4
diff --git a/semigroups-0.18.4.tar.gz b/semigroups-0.18.4.tar.gz
new file mode 100644
index 000000000000..2ee7f0e91ef7
--- /dev/null
+++ b/semigroups-0.18.4.tar.gz
Binary files differ