summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantinos2017-05-20 17:19:17 +0300
committerKonstantinos2017-05-20 17:19:17 +0300
commitc27fb852669ef50574c08c1940866a2724a18423 (patch)
tree4b6af9ac766d5547d27f5ce082e1983760502ae2
downloadaur-c27fb852669ef50574c08c1940866a2724a18423.tar.gz
useful commit message
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD62
2 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32f727e20ee3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = haskell-servant-client
+ pkgdesc = automatical derivation of querying functions for servant webservices
+ pkgver = 0.10
+ pkgrel = 1
+ url = https://haskell-servant.readthedocs.io
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = ghc
+ depends = haskell-aeson
+ depends = haskell-attoparsec
+ depends = haskell-base-compat
+ depends = haskell-base64-bytestring
+ depends = haskell-exceptions
+ depends = haskell-generics-sop
+ depends = haskell-http-api-data
+ depends = haskell-http-client
+ depends = haskell-http-client-tls
+ depends = haskell-http-media
+ depends = haskell-http-types
+ depends = haskell-monad-control
+ depends = haskell-mtl
+ depends = haskell-network-uri
+ depends = haskell-safe
+ depends = haskell-semigroupoids
+ depends = haskell-servant
+ depends = haskell-string-conversions
+ depends = haskell-text
+ depends = haskell-transformers-base
+ depends = haskell-transformers-compat
+ options = strip
+ options = staticlibs
+ source = https://hackage.haskell.org/packages/archive/servant-client/0.10/servant-client-0.10.tar.gz
+ sha256sums = 55e411ac7e38a5c1b77d8d3c2320369be36a7b7181e27bb5ac4fba308ef93eaa
+
+pkgname = haskell-servant-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed08dabd46d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_hkgname=servant-client
+pkgname=haskell-servant-client
+pkgver=0.10
+pkgrel=1
+pkgdesc="automatical derivation of querying functions for servant webservices"
+url="https://haskell-servant.readthedocs.io"
+license=("custom:BSD3")
+arch=('i686' 'x86_64')
+depends=('ghc'
+ 'haskell-aeson'
+ 'haskell-attoparsec'
+ 'haskell-base-compat'
+ 'haskell-base64-bytestring'
+ 'haskell-exceptions'
+ 'haskell-generics-sop'
+ 'haskell-http-api-data'
+ 'haskell-http-client'
+ 'haskell-http-client-tls'
+ 'haskell-http-media'
+ 'haskell-http-types'
+ 'haskell-monad-control'
+ 'haskell-mtl'
+ 'haskell-network-uri'
+ 'haskell-safe'
+ 'haskell-semigroupoids'
+ 'haskell-servant'
+ 'haskell-string-conversions'
+ 'haskell-text'
+ 'haskell-transformers-base'
+ 'haskell-transformers-compat')
+options=('strip' 'staticlibs')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('55e411ac7e38a5c1b77d8d3c2320369be36a7b7181e27bb5ac4fba308ef93eaa')
+
+build() {
+ cd "${_hkgname}-${pkgver}"
+
+ runhaskell Setup configure -O -p --enable-split-objs --enable-shared --prefix=/usr \
+ --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd "${_hkgname}-${pkgver}"
+
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: