summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcelo Garlet Millani2017-12-26 12:16:10 +0100
committerMarcelo Garlet Millani2017-12-26 12:16:10 +0100
commit02b1f4c1176b54ca2fb8133b657a8eb5969191df (patch)
tree9cccb4a769248cf6963569131ac2a403ebdf8a5c
parent4322326159f32d1d08b7465c1d1b696751883e1a (diff)
downloadaur-02b1f4c1176b54ca2fb8133b657a8eb5969191df.tar.gz
Dynamic flag for haddock.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b043cbf4e1a9..58763a2ec376 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = haskell-simtreelo
pkgdesc = Loads data organized in a tree
pkgver = 0.1.1.2
- pkgrel = 2
+ pkgrel = 3
url = http://hackage.haskell.org/package/simtreelo
install = haskell-simtreelo.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 11faee0e4658..9f54a740cf41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_hkgname=simtreelo
pkgname=haskell-simtreelo
pkgver=0.1.1.2
-pkgrel=2
+pkgrel=3
pkgdesc='Loads data organized in a tree'
url="http://hackage.haskell.org/package/${_hkgname}"
license=('GPL3')
@@ -15,12 +15,12 @@ install=${pkgname}.install
build() {
cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure -O --enable-split-objs --enable-shared \
- --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid \
- --gch-option -dynamic
+ runhaskell Setup configure -O --enable-shared --prefix=/usr \
+ --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option -dynamic
# runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O --enable-shared --enable-split-objs --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
- runhaskell Setup haddock
+ runhaskell Setup haddock --haddock-options "--optghc -dynamic"
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh