summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcelo Garlet Millani2015-07-04 11:55:53 -0300
committerMarcelo Garlet Millani2015-07-04 11:55:53 -0300
commiteff3882fe19e49b5678abf8ab52a29f00d0e17df (patch)
treee79ae114f79755a19f1b93a30d80bc91032cce0f
downloadaur-eff3882fe19e49b5678abf8ab52a29f00d0e17df.tar.gz
Moving from AUR3 to AUR4
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
-rw-r--r--haskell-simtreelo.install19
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f16182a07115
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haskell-simtreelo
+ pkgdesc = Loads data organized in a tree
+ pkgver = 0.1.1.0
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/simtreelo
+ install = haskell-simtreelo.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = ghc
+ source = http://hackage.haskell.org/package/simtreelo-0.1.1.0/simtreelo-0.1.1.0.tar.gz
+ sha256sums = 820e7189bb824c3480bb5492ddaf04a3b8200fea747084ab35e15ad46815f8c8
+
+pkgname = haskell-simtreelo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23f045ac32ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Marcelo Garlet Millani <marcelogmillani at gmail dot com>
+_hkgname=simtreelo
+pkgname=haskell-simtreelo
+pkgver=0.1.1.0
+pkgrel=1
+pkgdesc='Loads data organized in a tree'
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('GPL3')
+arch=('i686' 'x86_64')
+depends=('ghc')
+source=( "http://hackage.haskell.org/package/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz" )
+sha256sums=('820e7189bb824c3480bb5492ddaf04a3b8200fea747084ab35e15ad46815f8c8')
+install=${pkgname}.install
+
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+
+ runhaskell Setup configure -O --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ # runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O --enable-shared --enable-split-objs --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ mkdir -p ${pkgdir}/usr/share/man/man5
+ install -D -m 0644 simtreelo.5 ${pkgdir}/usr/share/man/man5/
+ gzip ${pkgdir}/usr/share/man/man5/simtreelo.5
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
+
diff --git a/haskell-simtreelo.install b/haskell-simtreelo.install
new file mode 100644
index 000000000000..ff5e956454ab
--- /dev/null
+++ b/haskell-simtreelo.install
@@ -0,0 +1,19 @@
+HS_DIR=usr/share/haskell/haskell-simtreelo
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+# ${HS_DIR}/unregister.sh
+ echo ""
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}