summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-10-01 09:15:27 +0200
committerAlexander F. Rødseth2022-10-01 09:15:27 +0200
commit10c937b5b3c4c2b798bb6487cfa2df6f7a1a983a (patch)
treed5f1ed3d49596f5b64dc852c772dffbcbb714705
downloadaur-10c937b5b3c4c2b798bb6487cfa2df6f7a1a983a.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD48
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1f649a501ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = haskell-vivid
+ pkgdesc = Sound synthesis with SuperCollider
+ pkgver = 0.5.2.0
+ pkgrel = 1
+ url = https://vivid-synth.com/
+ arch = x86_64
+ license = GPL
+ makedepends = ghc
+ makedepends = uusi
+ depends = ghc-libs
+ depends = haskell-hashable
+ depends = haskell-monadrandom
+ depends = haskell-network
+ depends = haskell-random-shuffle
+ depends = haskell-vivid-osc
+ depends = haskell-vivid-supercollider
+ depends = supercollider
+ source = https://hackage.haskell.org/packages/archive/vivid/0.5.2.0/vivid-0.5.2.0.tar.gz
+ b2sums = 210c76629107dbce602e635ab2a316983fee1cfba5839c3f43ce1d605e2ec73781c46c1f77b41b02d86c7e0f5798cbb9181b5e06d54b4aee0b97638f8a1a93f8
+
+pkgname = haskell-vivid
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1248d33bcd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+_hkgname=vivid
+pkgname=haskell-vivid
+pkgver=0.5.2.0
+pkgrel=1
+pkgdesc='Sound synthesis with SuperCollider'
+url='https://vivid-synth.com/'
+license=(GPL)
+arch=(x86_64)
+depends=(ghc-libs haskell-hashable haskell-monadrandom haskell-network haskell-random-shuffle haskell-vivid-osc haskell-vivid-supercollider supercollider)
+makedepends=(ghc uusi)
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-$pkgver.tar.gz")
+b2sums=('210c76629107dbce602e635ab2a316983fee1cfba5839c3f43ce1d605e2ec73781c46c1f77b41b02d86c7e0f5798cbb9181b5e06d54b4aee0b97638f8a1a93f8')
+
+prepare() {
+ cd $_hkgname-$pkgver
+ gen-setup
+ uusi -u base $_hkgname.cabal
+}
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
+ runhaskell Setup build $MAKEFLAGS
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+check() {
+ cd $_hkgname-$pkgver
+ runhaskell Setup test --show-details=direct
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ #install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ #rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}