summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:32:11 +0200
committerDaniel Nagy2015-06-08 20:32:11 +0200
commit4827701141d9735ac07b77c8cd0c6e364b04f2ab (patch)
tree149e9e81f0d54784d706c407c342e313abce329e
downloadaur-4827701141d9735ac07b77c8cd0c6e364b04f2ab.tar.gz
import to aur4
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD35
-rw-r--r--haskell-webkit.install18
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9931b485a082
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = haskell-webkit
+ pkgdesc = Binding to the Webkit library.
+ pkgver = 0.13.1.1
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/webkit
+ install = haskell-webkit.install
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ depends = ghc
+ depends = haskell-cairo>=0.13
+ depends = haskell-bytestring
+ depends = haskell-text
+ depends = haskell-mtl
+ depends = haskell-glib>=0.13
+ depends = haskell-gtk>=0.13
+ depends = haskell-pango>=0.13
+ depends = libwebkit
+ depends = gtk2hs-buildtools
+ depends = gtk2hs-buildtools
+ depends = gtk2hs-buildtools
+ options = strip
+ options = staticlibs
+ source = http://hackage.haskell.org/packages/archive/webkit/0.13.1.1/webkit-0.13.1.1.tar.gz
+ sha256sums = e53792e0c806d4a3de5ff929cf7d7e8c411db7169e84ce2a565201cc9356a218
+
+pkgname = haskell-webkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f9d5aefd9c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+_hkgname=webkit
+pkgname=haskell-webkit
+pkgver=0.13.1.1
+pkgrel=1
+pkgdesc="Binding to the Webkit library."
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+makedepends=()
+depends=('ghc' 'haskell-cairo>=0.13' 'haskell-bytestring' 'haskell-text' 'haskell-mtl' 'haskell-glib>=0.13' 'haskell-gtk>=0.13' 'haskell-pango>=0.13' 'libwebkit' 'gtk2hs-buildtools' 'gtk2hs-buildtools' 'gtk2hs-buildtools')
+options=('strip' 'staticlibs')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+}
+sha256sums=('e53792e0c806d4a3de5ff929cf7d7e8c411db7169e84ce2a565201cc9356a218')
diff --git a/haskell-webkit.install b/haskell-webkit.install
new file mode 100644
index 000000000000..c5b5b7dd5f27
--- /dev/null
+++ b/haskell-webkit.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-webkit
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}